Opened 5 months ago

Closed 2 months ago

Last modified 2 months ago

#15195 closed bug (duplicate)

Panic get boot partitions failed

Reported by: HAL Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/beta1
Keywords: boot, fails, kdl Cc: HAL
Blocked By: #15330 Blocking:
Has a Patch: no Platform: x86-64

Description

After updating to hrev53282 x86_64 and rebooting Haiku goes into KDL just after the middle icon. The summary of this bug is the first line of the KDL. If I reboot and select all the debug options it still does a KDL on next boot. Going back to my previous Haiku version hrev53233 x86_64, booting is good. I got a backtrace from KDL which I will upload from my camera when I reboot to Linux. I also got the old syslog that records the failed boot.

Attachments (10)

previous_syslog (171.9 KB ) - added by HAL 5 months ago.
100_1011.JPG (2.0 MB ) - added by HAL 5 months ago.
backtrace
syslog.old (512.0 KB ) - added by HAL 5 months ago.
100_1012.JPG (1.0 MB ) - added by HAL 5 months ago.
photo of boot log1
100_1013.JPG (1.3 MB ) - added by HAL 5 months ago.
photo of boot log2
100_1014.JPG (1.5 MB ) - added by HAL 5 months ago.
photo of boot log3
100_1015.JPG (1.5 MB ) - added by HAL 5 months ago.
photo of boot log4
syslog p16.JPG (2.1 MB ) - added by HAL 4 months ago.
Syslog p16
syslog p 17.JPG (1.6 MB ) - added by HAL 4 months ago.
Syslog p17
syslog p18.JPG (2.0 MB ) - added by HAL 4 months ago.
Syslog p18

Change History (28)

by HAL, 5 months ago

Attachment: previous_syslog added

by HAL, 5 months ago

Attachment: 100_1011.JPG added

backtrace

comment:1 by waddlesplash, 5 months ago

haiku-r1~beta1_hrev52295_129-1-x86_64.hpkg

Well, this is not a syslog from hrev53282. Are you sure you uploaded the right file?

comment:2 by HAL, 5 months ago

No I am unsure of the update hrev version number. When I made the bug report I had booted into another Haiku beta1. How do I tell what version from the syslog of other mounted Haiku partition?

comment:3 by waddlesplash, 5 months ago

Well, without the syslog from the failed boot, we can't possibly determine what the bug is.

by HAL, 5 months ago

Attachment: syslog.old added

comment:4 by HAL, 5 months ago

The hrev number in the report, I am uncertain that it was what I was testing. It was from Software Updater on the 21st July, yesterday. Where can I find the hrev from another Haiku mounted partition? I have just uploaded the syslog old. I hope that is the correct one.

comment:5 by waddlesplash, 5 months ago

This also contains no errors, the system appears to have booted successfully.

comment:6 by HAL, 5 months ago

Well somehow I have lost the correct syslog. In debug settings the option to show previous boot syslog was checked.

comment:7 by HAL, 5 months ago

I did a reboot to try and create a new syslog but none was created. It still went to KDL. Is that the reason no new syslog.

by HAL, 5 months ago

Attachment: 100_1012.JPG added

photo of boot log1

by HAL, 5 months ago

Attachment: 100_1013.JPG added

photo of boot log2

by HAL, 5 months ago

Attachment: 100_1014.JPG added

photo of boot log3

by HAL, 5 months ago

Attachment: 100_1015.JPG added

photo of boot log4

comment:8 by HAL, 5 months ago

I attached photos of relevant boot log screens.

comment:9 by HAL, 4 months ago

The Haiku revision I reported as updating to in the bug discription was a bit wrong, It was actually hrev53280. After booting from an ealier revision and doing another update, the update is reported as updating from hrev53280.

comment:10 by diver, 4 months ago

The images you attached do not contain a panic message. It looks like you entered "Display previous syslog" menu in the bootloader and took pics of it. Please provide pictures of syslog which end with panic.

comment:11 by HAL, 4 months ago

I booted again until it KDL'd then typed syslog. I took pictures of all pages. There are 18. Do I attach them all or just the last?

comment:12 by diver, 4 months ago

Lets see the last 3 for a start :)

by HAL, 4 months ago

Attachment: syslog p16.JPG added

Syslog p16

by HAL, 4 months ago

Attachment: syslog p 17.JPG added

Syslog p17

by HAL, 4 months ago

Attachment: syslog p18.JPG added

Syslog p18

comment:13 by HAL, 4 months ago

Last 3 pages of syslog attached.

comment:14 by diver, 4 months ago

At least we have some error now: KDiskDeviceManager::InitialDeviceScan() failed: Bad data

comment:15 by HAL, 2 months ago

I think KDiskDeviceManager:InitialDeviceScan() failed: Bad data, is cause from updating the OS with Software Updater. Not necessarily from Software Updater itself but doing it this way instead of overwriting the Haiku install with the latest Haiku from USB stick. Just overwriting from USB stick, after install I can boot with no KDL at middle progress boot icon. This seems to be the common cure for quite a few problems of what seem like different bugs, that I cannot remember all, in the past. So is this a bug with Software Updater or indirectly stems from it? The "Bad data" is this some corruption caused when updating with SoftwareUpdater?

comment:16 by waddlesplash, 2 months ago

Blocked By: 15330 added
Resolution: duplicate
Status: newclosed

Actually that error was also the cause of #15330, which was since fixed.

comment:17 by HAL, 2 months ago

Why was my bug report here marked as duplicate when it was reported before #15330? I find with many of my reports marked duplicate when I have reported before the same bug.

comment:18 by waddlesplash, 2 months ago

Usually we close as duplicates in favor of the earliest opened, but if it is later discovered that an already-fixed issue has a still-open duplicate, we close it as a duplicate of the now-fixed bug, no matter older or newer.

Note: See TracTickets for help on using tickets.