Opened 12 years ago

Closed 11 years ago

#1525 closed bug (fixed)

Haiku fails to detect CDs regardless of filesystem on nforce4 ATAPI

Reported by: anevilyak Owned by: bonefish
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've tried an ISO9660 CD, a Joliet CD, and also the R5 Pro hybrid CD. In none of said cases does the mount menu detect the volume, nor does mounting manually via the command line work (invalid argument). The CD drive itself appears to be detected though, as an entry is present in devfs at /dev/atapi/4/master/raw, and is hosted on an nforce4's PATA channels (its sister SATA controller is correctly recognizing and booting from the hdd on SATA).

Motherboard: Asus A8N-SLI (Nforce4 + PCI Express, on-board nvidia SATA and PATA controllers)

Please let me know what extra debug info would be useful.

Change History (5)

comment:1 by axeld, 12 years ago

Owner: changed from axeld to bonefish

I guess you haven't put in the CD from the start on, but have switched it while Haiku was running? If so, it's more or less a duplicate of #1052 :-) The disk device manager currently does not check for any changes.

comment:2 by jackburton, 11 years ago

Is this fixed now ?

comment:3 by anevilyak, 11 years ago

I want to say on the fly detection of CDs is fixed now, though this still leaves the (known) issue that the ata bus manager which I'm currently using doesn't support ATAPI at all yet, so I'd have to switch back to ide to verify. Will do hopefully later today.

comment:4 by scottmc, 11 years ago

Is this still broken for you? Seems recent changes have it working on my laptop which has an nvidia chipset.

comment:5 by anevilyak, 11 years ago

Resolution: fixed
Status: newclosed

Thanks for the reminder, this one is indeed fixed, I'd forgotten about it.

Note: See TracTickets for help on using tickets.