Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#15309 closed bug (duplicate)

Haiku crashes without KDL

Reported by: un_spacyar Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: #15264 Blocking:
Platform: All

Description

I had several crashes. It doesn't show a KDL. Just the Desktop freezes, with just me mouse pointer working. The Alt+Control+Del don't bring the process control, and usually just freezes the mouse pointer.

I'm using hrev53393 (x86_gcc2), on real hardware.

Usually, this crash appears under heavy load.

In the syslog, I get the following message:

Last message repeated 1 time
KERN: Last message repeated 4 times.
KERN: Last message repeated 2 times.
KERN: low resource memory: note -> warning
KERN: bfs: bfs_access:1564: Permission denied
KERN: Last message repeated 2 times.
KERN: low resource memory: warning -> note
KERN: bfs: bfs_access:1564: Permission denied
KERN: Last message repeated 2 times.
KERN: Last message repeated 3 times.
Last message repeated 1 time
KERN: acquire_advisory_lock(vnode = 0x930577f0, flock = 0x81d9cefc, wait = no)
KERN: Last message repeated 9 times.
KERN: acquire_advisory_lock(vnode = 0x93057de0, flock = 0x81d9cefc, wait = no)
KERN: Last message repeated 5 times.
KERN: low resource memory: note -> critical
KERN: acquire_advisory_lock(vnode = 0x93057de0, flock = 0x81d9cefc, wait = no)
KERN: Last message repeated 5 times.
KERN: low resource memory: critical -> warning
KERN: acquire_advisory_lock(vnode = 0x93057de0, flock = 0x81d9cefc, wait = no)
KERN: Last message repeated 24 times.
KERN: low resource memory: warning -> critical
KERN: 0xfa49b528->VMAnonymousCache::_Commit(131072): Failed to reserve 131072 bytes of RAM
KERN: 336903: DEBUGGER: abort() called
KERN: 0xfa49b528->VMAnonymousCache::_Commit(4259840): Failed to reserve 4259840 bytes of RAM
KERN: Last message repeated 2 times.
KERN: vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x1964711, write 1, user 1, thread 0x5251c

Attachments (1)

log_2019-08-26.txt (39.8 KB ) - added by un_spacyar 10 months ago.
Syslog

Download all attachments as: .zip

Change History (3)

by un_spacyar, 10 months ago

Attachment: log_2019-08-26.txt added

Syslog

comment:1 by waddlesplash, 10 months ago

Resolution: duplicate
Status: newclosed

This is an OOM, most likely caused by the same factors as #15264.

comment:2 by waddlesplash, 10 months ago

Blocked By: 15264 added
Note: See TracTickets for help on using tickets.