Opened 10 months ago

Closed 10 months ago

Last modified 3 months ago

#15318 closed bug (fixed)

Verifying new users does not work

Reported by: pulkomandy Owned by: nielx
Priority: normal Milestone:
Component: Website/Trac Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

The verification e-mail looks like this:

Please visit the following URL to confirm your email address. Verification URL: <$verify.link> Username: $account.username Verification Token: $account.token

And trying to approve the user manually from the Admin/Users page results in:

Oops…
Trac detected an internal error:
TypeError: 'Fragment' object is not callable
This is probably a local installation issue.

Found a bug in Trac?

If you think this should work and you can reproduce the problem, you should consider creating a bug report.

Note that the TracAccountManager plugin seems to be involved. Please report this issue to the plugin maintainer.

Before you do that, though, please first try searching for similar issues , as it is quite likely that this problem has been reported before. For questions about installation and configuration of Trac or its plugins, please try the mailing list instead of creating a ticket.

Otherwise, please   a new bug report describing the problem and explain how to reproduce it.

Python Traceback

Most recent call last:
File "/usr/local/lib/python2.7/site-packages/trac/web/main.py", line 639, in dispatch_request          
  dispatcher.dispatch(req)
File "/usr/local/lib/python2.7/site-packages/trac/web/main.py", line 250, in dispatch          
  resp = chosen_handler.process_request(req)
File "/usr/local/lib/python2.7/site-packages/trac/admin/web_ui.py", line 103, in process_request          
  resp = provider.render_admin_panel(req, cat_id, panel_id, path_info)
File "build/bdist.linux-x86_64/egg/acct_mgr/admin.py", line 219, in render_admin_panel          
  return self._do_users(req)
File "build/bdist.linux-x86_64/egg/acct_mgr/admin.py", line 618, in _do_users          
  len(ban), accounts=accounts))

Change History (3)

comment:1 by nielx, 10 months ago

Status: assignedin-progress

I will be looking at it later today.

comment:2 by nielx, 10 months ago

Resolution: fixed
Status: in-progressclosed

The email verification problem should be fixed.

The other issue is valid, but I won't fix it. While the function is broken, it does not pertain to the verification of users, but instead is meant to block/unblock accounts. Since this is not a function we use, I don't think we should fix it.

comment:3 by nielx, 3 months ago

Milestone: Unscheduled

Remove milestone from web and sys-admin tickets.

Note: See TracTickets for help on using tickets.