Opened 3 months ago

Closed 3 months ago

#15324 closed bug (no change required)

Almost all system freezes after opening YouTube in WebPositive

Reported by: ChronosX88 Owned by: nobody
Priority: critical Milestone: R1
Component: Drivers/Network/pcnet Version: R1/beta1
Keywords: Cc:
Blocked By: Blocking: #15325
Has a Patch: no Platform: x86-64

Description (last modified by ChronosX88)

Almost all system freezes after opening YouTube in WebPositive - including Tracker. Kernel process called "pcn intr handler" eats one CPU core (25%). Screenshot of top utility is attached to ticket. Running Haiku on VBox (host is Linux).

Attachments (1)

Screenshot_20190901_141737.png (110.7 KB ) - added by ChronosX88 3 months ago.

Download all attachments as: .zip

Change History (6)

by ChronosX88, 3 months ago

comment:1 by ChronosX88, 3 months ago

Description: modified (diff)

comment:2 by ChronosX88, 3 months ago

Description: modified (diff)

comment:3 by pulkomandy, 3 months ago

Component: - GeneralDrivers/Network/pcnet

In the top output I can see the pcnet driver interrupt using 100% CPU. After asking on IRC, this is on a virtual machine, so a workaround is to use a different network card. Yet, we should somehow make this driver behave properly?

comment:4 by pulkomandy, 3 months ago

Blocking: 15325 added

comment:5 by waddlesplash, 3 months ago

Resolution: no change required
Status: newclosed

This was a known problem in VirtualBox: https://www.virtualbox.org/ticket/1067

It appears they finally fixed it this past May: https://www.virtualbox.org/ticket/1067

So, there's nothing we can do here. If you are on an older VirtualBox version, use the Intel network adapter as both we and they suggest.

Note: See TracTickets for help on using tickets.