Opened 12 years ago

Closed 10 years ago

#1535 closed bug (fixed)

Lock up on system while using regular NVIDIA driver.

Reported by: etteyafed Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

The system in question is a HP Pavilion dv6000 with an Intel Core 2 Duo 5400 1.7ghz and 2gb ram. The chipset is Intel 945GM.

Experienced behavior: When I try to move a window the whole system locks up including the mouse. The kernel debugger is accessible by pressing F12 but it does not open automatically.

Expected behavior: The window moves as usual.

How to reproduce: Try to move a window on the desktop.

This issue is relevant to Rev. 22437 last I checked. I will verify this with 22450 ASAP and update with any changes.

This system has no serial port so I might have to get a USB->Serial adapter for more info. I couldn't find anything in kdbg that looked wrong (but I didn't really know what to look for).

Change History (6)

comment:1 in reply to:  description ; Changed 12 years ago by etteyafed

Summary: Lock up on SMP systems.Lock up on system while using regular NVIDIA driver.

Replying to etteyafed: It this problem goes away if I enable failsafe video mode. The card I am using is an embedded GeForce Go 7400.

comment:2 Changed 12 years ago by etteyafed

Component: - User InterfaceDrivers/Graphics/nVidia
Owner: changed from stippi to axeld

comment:3 Changed 12 years ago by etteyafed

This is a hi res photo of a back-trace after the lock up.

http://etteyafed.homeip.net/images/haiku_debug/img-1.html

comment:4 in reply to:  1 Changed 12 years ago by etteyafed

Another strange issue: If I try and boot normally I get a vm_page_fault. If I enable failsafe video mode this won't happen. This is not the same as the lock up described but may be related. Disabling IDE DMA also causes this to go away (this is the only way I can boot with the regular nvidia driver). I don't know what disabling the nvidia driver and disabling IDE DMA have in common but they both prevent this vm_page_fault. They don't both need to be enabled, just one or the other. Here is a link to the ri res photo of the page_fault: http://etteyafed.homeip.net/images/haiku_debug/img-2.html

comment:5 Changed 12 years ago by scottmc

For attaching photos to bug reports you should upload them using trac rather than hosting them offsite, just use the attach file button.

comment:6 Changed 10 years ago by rudolfc

Resolution: fixed
Status: newclosed

Hi,

The acceleration engine wasn't properly powered up up for G72 cards (Geforce 7300, 7400 and 7500) at least.

Fixed since R30783, so closing ticket.

Testable only with pre-R30278 builds, since app_server unfortunately nolonger uses acceleration since then..

Bye!

Rudolf.

Note: See TracTickets for help on using tickets.