Opened 11 months ago

Closed 8 months ago

Last modified 4 months ago

#15380 closed bug (fixed)

[bootloader] Continue booting is greyed out

Reported by: lorglas Owned by: leavengood
Priority: critical Milestone: R1/beta2
Component: System/Boot Loader Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

After I updating the system to the hrev 53511, I can in the bootloader menu Continue booting no longer execute me only reboot remains.

Attachments (8)

bild1.jpg (2.1 MB ) - added by lorglas 10 months ago.
selelection of installed system
bild2.jpg (2.0 MB ) - added by lorglas 10 months ago.
after system 32 bit is selected, called nigthly
bild3.jpg (1.9 MB ) - added by lorglas 10 months ago.
Continue booting is disable
bild4.jpg (1.9 MB ) - added by lorglas 10 months ago.
i choose failsafe graphics and a optimal resolution for my laptop, continue booting is disable
bild5.jpg (1.9 MB ) - added by lorglas 10 months ago.
after pressing reboot, i land in the boot loader death land
haiku_loader-r1~beta1_hrev53365-1-x86_64.hpkg (308.5 KB ) - added by diver 8 months ago.
syslog (301.4 KB ) - added by lorglas 8 months ago.
syslog.old (512.0 KB ) - added by lorglas 8 months ago.

Change History (26)

by lorglas, 10 months ago

Attachment: bild1.jpg added

selelection of installed system

by lorglas, 10 months ago

Attachment: bild2.jpg added

after system 32 bit is selected, called nigthly

by lorglas, 10 months ago

Attachment: bild3.jpg added

Continue booting is disable

by lorglas, 10 months ago

Attachment: bild4.jpg added

i choose failsafe graphics and a optimal resolution for my laptop, continue booting is disable

by lorglas, 10 months ago

Attachment: bild5.jpg added

after pressing reboot, i land in the boot loader death land

comment:1 by lorglas, 10 months ago

I have added 5 images to make the steps understandable. the problem occurred after the update.

comment:2 by diver, 10 months ago

Milestone: R1/beta2
Owner: changed from nobody to leavengood
Platform: x86All
Status: newassigned
Summary: bootloader[bootloader] Continue booting is greyed out

Quite a few users mentioned this recently. Probably a regression after hrev53370.

comment:3 by pulkomandy, 9 months ago

Priority: highcritical

It would be nice to fix this or at least have a hint about what the actual problem is (error message or something) for beta2.

comment:4 by diver, 8 months ago

I downloaded https://s3.wasabisys.com/haiku-nightly/x86_64/haiku-master-hrev53365-x86_64-anyboot.zip and extracted haiku_loader-r1~beta1_hrev53365-1-x86_64.hpkg from there. With this version Continue booting menu item is enabled.

comment:5 by waddlesplash, 8 months ago

Resolution: fixed
Status: assignedclosed

Fixed in hrev53650.

comment:6 by lorglas, 8 months ago

The problem is not solved.

I have updated my system to Hrev 53655 (64 bit) and Hrev 53649 (32 bit). The problem described above can be seen from Picture 4. Continue Booting remains grayed out.

comment:7 by lorglas, 8 months ago

Resolution: fixed
Status: closedreopened

comment:8 by pulkomandy, 8 months ago

You need to update the bootloader in your EFI partition, as the bug was there. Did you do that when updating? It is still a manual process.

comment:9 by bruno, 8 months ago

a manual process? Ok... how to do that?

As I fiddled around with the EFI bootloader I can now "continue booting" after going forth and back the menu...with hrev 53650 64bit nightly...

comment:10 by waddlesplash, 8 months ago

lorglas: I definitely tested it before and after I made that commit, and the commit definitely fixes the issue for me. Please double-check what installed haiku_loader you have; and get a serial log from the bootloader if you really have the correct haiku_loader installed.

comment:11 by waddlesplash, 8 months ago

Milestone: R1/beta2Unscheduled

comment:12 by iam-alex, 8 months ago

Just want to say I don't think that problem somehow related to (U)EFI. I have the same issue ("Continue booting" is greyed out if I try to boot any previous state except latest one) on both my 9 years old 32 (latest hrev53649) and 64 bit laptops, which definitely hasn't UEFI.

Edit: I'm stupid. Will wait for new 32 bit revisions.

Last edited 8 months ago by iam-alex (previous) (diff)

comment:13 by iam-alex, 8 months ago

(Just for information) I've checked this issue on both recent 32 (hrev53658) and 64 bit Haiku. Problem is solved for me.

by lorglas, 8 months ago

Attachment: syslog added

by lorglas, 8 months ago

Attachment: syslog.old added

comment:14 by lorglas, 8 months ago

Hello, i don't use UEFI. I use Bios and then Grub 2 to load Haiku, because i have some other system on the harddisk.

I added two syslog from my pc

Last edited 8 months ago by lorglas (previous) (diff)

in reply to:  14 comment:15 by diver, 8 months ago

Replying to lorglas: you're running Haiku revision before the fix (hrev53649). You need hrev53650 or later.

comment:16 by waddlesplash, 8 months ago

Resolution: fixed
Status: reopenedclosed

So, then this ticket was reopened in error. A number of other users who were experiencing this bug also reported it is now gone, so this is definitely fixed.

I've added error messages to the menu item in hrev53659, so any other issues should be more easily diagnoseable now.

comment:17 by lorglas, 8 months ago

Thank you, it is working.

comment:18 by nielx, 4 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.