Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#154 closed bug (invalid)

Please add B_AVOID_FOCUS to TBarWindow.

Reported by: bxi07354@… Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

src/apps/deskbar/BarWindow.cpp

Please add B_AVOUD_FOCUS to TBarWindow. TBarWindow::TBarWindow()

: BWindow(BRect(-1000.0f, -1000.0f, -1000.0f, -1000.0f), "Deskbar",

B_BORDERED_WINDOW, B_WILL_ACCEPT_FIRST_CLICK | B_NOT_ZOOMABLE | B_NOT_CLOSABLE

| B_NOT_MOVABLE | B_AVOID_FRONT | B_ASYNCHRONOUS_CONTROLS | B_AVOID_FOCUS,

B_ALL_WORKSPACES)

Change History (10)

comment:1 Changed 13 years ago by korli

Owner: changed from sikosis to axeld

comment:2 Changed 13 years ago by korli

Summary: Please add B_AVOUD_FOCUS to TBarWindow. Please add B_AVOUD_FOCUS to TBarWindow.

comment:3 Changed 13 years ago by axeld

This would break add-ons that need keyboard input. Any reason for wanting to have that flag set, anyway?

comment:4 Changed 13 years ago by axeld

Resolution: invalid

comment:5 Changed 13 years ago by axeld

Status: newclosed

comment:6 Changed 13 years ago by bxi07354@…

SetFocus does Deskbar to Desktop::SetFocusWindow()

Procedure launch StyledEdit (Active) ALT+space bar (canna active) --> Deskbar(SetFocus) --> StyledEdit(deactive)

comment:7 Changed 13 years ago by axeld

Is that procedure reproducible when you're using the canna input method under R5? Because that sounds like a bug to me that shouldn't be hidden this way, even if it worked.

comment:8 Changed 13 years ago by axeld

Summary: Please add B_AVOUD_FOCUS to TBarWindow.Please add B_AVOID_FOCUS to TBarWindow.

comment:9 Changed 13 years ago by bxi07354@…

# hey "application/x-vnd.Be-TSKB" Get Flags of Window 1 Reply BMessage(B_REPLY):

"result" (B_INT32_TYPE) : 524529 (0x000800F1)

It did not become it so in hrev5. It is another reason. Therefore, it withdraws.

Is that procedure reproducible when you're using the canna input method under R5?

case R5 launch StyledEdit (Active) ALT+space bar (canna active)

case Haiku launch StyledEdit (Active) ALT+space bar (canna active) --> Deskbar(SetFocus) --> StyledEdit(deactive)

comment:10 Changed 13 years ago by korli

bug_group: developers
Note: See TracTickets for help on using tickets.