Opened 10 months ago

Closed 6 months ago

Last modified 4 months ago

#15433 closed bug (fixed)

media_addon_server crash in "Preferences > Media"

Reported by: WildKeccak Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

On my machine, it is possible to crash media_addon_server through Preferences > Media. It may or may not be enhanced by checking and unchecking Show Volume in Taskbar. As in #15263, you cannot save anything or debug anything.

Attachments (1)

screenshot1.png (218.6 KB ) - added by WildKeccak 10 months ago.
This is a picture of my messy desktop, after I have tried and succeeded in reproducing the bug.

Download all attachments as: .zip

Change History (11)

by WildKeccak, 10 months ago

Attachment: screenshot1.png added

This is a picture of my messy desktop, after I have tried and succeeded in reproducing the bug.

comment:1 by nephele, 10 months ago

any specific tasks to do to get it to crash? I have player around a bit in it but apart from some reall bad ui behaviour havent found anything. (the ui behaviour here beeing that clickign checkboxes in tab2 sends you back to tab1 which is hugely frustrating)

Also, which revision are you on?

Last edited 10 months ago by nephele (previous) (diff)

comment:2 by WildKeccak, 10 months ago

Yes, you check the Show volume control on Deskbar, then Restart media services. I have to repeat that about 5 times before it triggers. More or less 5 times.

comment:3 by nephele, 10 months ago

What do you mean with 'check the Show volume control on Deskbar'? I haven't found any such controll on Deskbar.

edit: I found what you ment, but sadly i cannot reproduce the crash.

please still include the revision :), you can find it in the "about haiku" option in deksbar.

Last edited 10 months ago by nephele (previous) (diff)

comment:4 by WildKeccak, 10 months ago

oh, hrev53559

AMD Ryzen 5 3400G

comment:5 by diver, 10 months ago

Looks like both Media and media_addon_server crashed. Try to save and upload debug reports.

comment:6 by WildKeccak, 10 months ago

On my machine, only media_addon_server crash. My motherboard is MSI X570 A Pro.

comment:7 by korli, 6 months ago

Please check with hrev53876 or newer.

comment:8 by WildKeccak, 6 months ago

It seems to be in working order.

comment:9 by waddlesplash, 6 months ago

Resolution: fixed
Status: newclosed

Thanks for testing.

comment:10 by nielx, 4 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.