Opened 8 months ago

Closed 7 months ago

Last modified 3 months ago

#15454 closed bug (fixed)

Miissing Web+ strings at pootle

Reported by: humdinger Owned by: nielx
Priority: normal Milestone:
Component: Website/Pootle Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

For some reason, some newer strings for "Start up" and its menu items in the settings window of web+ are missing at pootle. Looks all good in the code, see https://git.haiku-os.org/haiku/tree/src/apps/webpositive/SettingsWindow.cpp#n282 ff

Change History (4)

comment:1 by nielx, 7 months ago

Status: newin-progress

There is something fishy going on. The build output on the server does not look right. On my local machine I also get a different fingerprint than the file on the server, and the file on the server does not seem to get regenerated.

This has probably something to do with the no-download options we use. It needs more investigation.

comment:2 by pulkomandy, 7 months ago

Web+ needs HaikuWebKit to be built, so indeed, if you disable downloads and don't have that package (up to date) around, this would not work?

comment:3 by nielx, 7 months ago

Resolution: fixed
Status: in-progressclosed

For various reasons it is preferred that the Docker image that runs Pootle also builds the catkeys. The issue is that the image runs from within the Haiku network, so the public facing urls (like eu.hpkg.haiku-os.org) are not available. It is possible to run a jam catkeys without downloads, but the catkeys for WebPositive are behind a feature gate.

I now fixed the issue by explicitly enabling the webkit feature in the UserBuildConfig. This is documented in this commit in the haiku infrastructure repository.

Web+ strings will be updated in the weekly run on Saturday.

comment:4 by nielx, 3 months ago

Milestone: Unscheduled

Remove milestone from web and sys-admin tickets.

Note: See TracTickets for help on using tickets.