Opened 9 months ago

Closed 8 months ago

#15490 closed bug (duplicate)

KDL "did not find any boot partitions" on USB3 system.

Reported by: yochanon Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/beta1
Keywords: Cc:
Blocked By: #15000 Blocking:
Platform: x86-64

Description

I just downloaded and installed with dd on my linux system, haiku-r1beta1-x86_64-anyboot.zip to 2 different flashdrives.

When I reboot my system Haiku starts by putting the little icons on the screen that show what is initializing (I guess is what's happening).

Unfortunately before anything shows or highlights that it initialized, a white section of the top of the screen shows up with black lettering announcing some kind of kernel panic.

It did the same exact thing on the other flashdrive, and I've had other linux distros on both the drives so I know they're both good.

I'll attach a inxi text to show what my system is comprised of and maybe that will help someone there. I really can't wait to try out Haiku so I figure the more systems it's tried on, the more help it offers you guys...or at least I hope I'm correct.

If you need more information, I can also take a picture of the screen if that would be of any help too.

Attachments (2)

system_info.txt (1.6 KB ) - added by yochanon 9 months ago.
hrev53591_nightly.jpg (627.5 KB ) - added by yochanon 9 months ago.

Download all attachments as: .zip

Change History (9)

by yochanon, 9 months ago

Attachment: system_info.txt added

comment:1 by humdinger, 9 months ago

Thanks for testing. Please try with a nightly image. There have been massive changes since Beta1. It may have been fixed already. If it persists, please take a photo of the panic.

comment:2 by yochanon, 9 months ago

Okay, I tried with hrev53591 and it still happened. I've attached a picture of the screen with the panic.

by yochanon, 9 months ago

Attachment: hrev53591_nightly.jpg added

comment:3 by humdinger, 9 months ago

Thanks. Not sure the KDL photo offers useful info, let's see if anyone knows what's going on...

comment:4 by waddlesplash, 9 months ago

Are you attempting to boot off a USB3 drive? Try a USB2 drive or port.

comment:5 by yochanon, 9 months ago

All I have are USB3 drives, but I plugged one into a USB2 port and it booted to the desktop, but froze there but when I rebooted it went to the desktop just fine.

Unfortunately it froze often, the desktop.

It could happen when simply opening the main menu when clicking on the 'feather' in the upper right corner, or in another instance when I accidentally changed the 'bold font' to 'regular' in the system look and feel.

The haikudepot (I think that's what it was called) worked with one download, and that was Haiku extras. Whenever I tried anything else, it kept popping up a small window saying it couldn't do it and had parenthises with nothing between them, like this () .

The web browser, webpositive, would load fine and go right to a Haiku site (I think it was a help site or some such), but every time I tried to go to another site, whether from clicking a link (as in the haikudepot) or typing it in, it froze up.

It showed in 'tracker' though that it was still up even after I'd closed the window.

When I opened it again from the main menu, I opened up the 'preferences' (I think it was called something else...yeah, I suck at this testing thing, sorry) and the smaller window popped up, all was fine until I moved the smaller window...then it started leaving paint traces anywhere I moved it, and I'd even moved it over Haikudepot and that completely froze all three windows and wouldn't allow me to close any of them. Even a Ctrl-Alt-Del brought up the 'kill' menu, but that had no affect whatsoever (and it also showed that there *were* still other instances of webpositive still running in the background).

Good things though...the music played just fine - ogg's, flac's and mp3's.

I was able to see all my other drives and they would mount just fine and I could copy or move back and forth easily between the Haiku flashdrive system and the other drives on my computer.

I was able to set the system to 1920x1080 and use one of my pictures I'd brought over from my Slackware 14.1 HDD as a background on the desktop.

It will take me a *lot* of playing with Haiku to figure everything out. I like to have the background change every 20 or 30 minutes using the pictures I have in a directory, but I couldn't figure it out where that was or if it even had it in Haiku as the system just kept freezing too much that it finally got too frustrating.

I was on the system the longest time for about an hour, I believe. Other times varied from 3 minutes to 20 or 30 minutes before a system freeze.

All times after the system froze, I had to do a hard reset with the button on my tower as Haiku was absolutely responding to nothing.

It still looked good and I think I might actually like it once it gets more stable.

Tell me what else I can do to help. I know I should write things down more often, but that's a viscious circle for me that goes like this because of a severe memory problem I now have had since 1989 from having encephalitis;

I can get a pen and paper and set them in front of me or put them in my pocket for use later.

I then forget I even have either of those thing or that I want or need to write anything down.

If I happen to write anything down, I forget that I'd done that and that paper simply gets thrown away later or mixed into all the other mess on my desk.

If I actually remember I need to write something down, I can't remember where I put pen and paper.

And on and on and on, ad nauseum. But, I try, and hopefully that is *some* help, like what little I've done these past few days.

So, tell me what you need done. More testing of nightly builds? Is my explanations helping at all? What can I do to make my tests 'better' and actually helpful if this wasn't quite enough?

comment:6 by pulkomandy, 8 months ago

Summary: Kernel panic on my system...KDL "did not find any boot partitions" on USB3 system.

comment:7 by waddlesplash, 8 months ago

Blocked By: 15000 added
Resolution: duplicate
Status: newclosed

Not being able to boot off USB3 is already tracked in #15000.

Note: See TracTickets for help on using tickets.