Opened 7 weeks ago

Last modified 4 weeks ago

#15505 new bug

Haiku Kernal Panic when booting from USB - Dell E6430

Reported by: erik.bamberg Owned by: mmlr
Priority: normal Milestone: Unscheduled
Component: Drivers/USB/EHCI Version: R1/Development
Keywords: Kernal Panic, Boot, Dell E6430 Cc: erik.bamberg@…
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

I tried to boot Haiku from on USB stick on my Dell Latitude E6430 laptop. I used the anyboot image for x64-64 systems.

booting is slow. After choosing a language and "start desktop" I see the kernal panic message and cannot boot to the desktop.

I tried debug options and disable all controllers I found in the bootloader. I can start the desktop then, but after the first click to start an app or open a folder I see the Kernal Panic Page again.

I attached a screenshot of this.

With the nightly build I can boot to the desktop, don't see any applications and system crashes when I try to open any application.

I am new to Haiku, tested BeOS years ago with the same result that it was not possible to boot on my machines. As an older amiga developer I really would like to contribute to the system :-).

Attachments (3)

Haiku_KernalPanic_small.JPG (2.5 MB ) - added by erik.bamberg 7 weeks ago.
screenshoot kernal panic after booting the system
Haiku_KernalPanichref53610_small.JPG (3.1 MB ) - added by erik.bamberg 7 weeks ago.
kernal panic with href53610
syslog (185.4 KB ) - added by erik.bamberg 4 weeks ago.
syslog after applications crashes

Change History (24)

by erik.bamberg, 7 weeks ago

Attachment: Haiku_KernalPanic_small.JPG added

screenshoot kernal panic after booting the system

comment:1 by diver, 7 weeks ago

Please try with a nightly image instead of beta1 from here https://download.haiku-os.org/nightly-images/x86_64/

comment:2 by erik.bamberg, 7 weeks ago

As mentioned in the ticket. I already have tried with a nightly build from yesterday. Doesn't work.

comment:3 by erik.bamberg, 7 weeks ago

But might be another error. I can try tomorrow

comment:4 by waddlesplash, 7 weeks ago

The image attached here was most definitely fixed since beta1, so yes, it is undoubtedly another error.

Please try a USB2 drive or port if this is USB3.

comment:5 by erik.bamberg, 7 weeks ago

I tested to boot with the latest nightly build href53610 but still get an kernal panic message on startup.

I will attach a screenshot

by erik.bamberg, 7 weeks ago

kernal panic with href53610

comment:6 by diver, 7 weeks ago

Please try again after hrev53612.

comment:7 by erik.bamberg, 7 weeks ago

doesn't work with hrev53618. But issue changed

When booting in UEFI mode I see the language selector window. when I click start desktop nothing happens !

When booting in legacy mode I see desktop in chinese or japanese but cannot start a single application. every application crashes cannot even start debugger, cause also the debugger crashes.

In both cases the WIFI-LED on my aptop flashes the whole time. Usually the light is steady and doesn't flash.

So still no succesy in starting Haiku.

comment:8 by waddlesplash, 7 weeks ago

How much RAM is used?

comment:9 by erik.bamberg, 7 weeks ago

16gb of RAM

And I use the haiku 64bit version because of the memory of course.

comment:10 by waddlesplash, 7 weeks ago

If you Ctrl+Alt+Del, can you select Restart The Desktop?

comment:11 by erik.bamberg, 7 weeks ago

Yes I can restart after strg-ctrl-del. After the reboot I was able to change language to a mixture of German and English. Funny thing is that I can boot now every time. But WLAN preferences crashes as well as most of the apps. The WLAN-led still flashes the whole time. I cannot use haikodepot cause of no network and cannot select a network cause of the crashes. Very unstable.

comment:12 by waddlesplash, 7 weeks ago

Can you post a syslog after some of the crashes?

comment:13 by erik.bamberg, 6 weeks ago

No I think I cannot. Also the debugger crashes. When I choose save report or write core file or what ever, then the debugger crashes. Every application just crashes.

comment:14 by waddlesplash, 6 weeks ago

The file is just /var/log/syslog, why can you not copy this and upload it?

comment:15 by erik.bamberg, 6 weeks ago

please advise me how to copy and upload this file when every app crashes. Any ideas ?

I cannot access the filesystem cause every application crashes. Even if I could I would not be able to upload because network not works cause wlan preference crashes as well. Can i access a Windows7 HD from the haiku instance to copy the file there? .

The filesystem on the usb stick is BeOS-FS, so I cannot access the filesystem from outsite by running windows or linux and mount this USB stick.

So how can I access the syslog file on the crashing instance ?

comment:16 by X512, 6 weeks ago

You can attach USB stick to a virtual machine such as VirtualBox.

comment:17 by erik.bamberg, 6 weeks ago

I tried this. Can start haiku in virtual box. How do I mount the stick? Something like mount /dev/usb0?

Haiku does not seem to autodetect the stick.

comment:18 by X512, 6 weeks ago

VirtualBox require extension pack to support USB. USB device can be attached by USB icon under VirtualBox window. Disk devices should be listed in DriveSetup (Leaf menu > Applications > DriveSetup).

comment:19 by erik.bamberg, 4 weeks ago

sorry pre chrismas stress... so yeah I finally managed to run Haiku in Virtual Box with USb support and network . Yeah !

So I have access to the log file and can attach them here.

Find the system.log attached. Let me know if I can test and provide you with something else...

Let me know what you guys found out, maybe a good start point into Haiku development ;-)

by erik.bamberg, 4 weeks ago

Attachment: syslog added

syslog after applications crashes

comment:20 by diver, 4 weeks ago

Component: System/KernelDrivers/USB/EHCI
Owner: changed from nobody to mmlr
Version: R1/beta1R1/Development

Seems to be USB2 related:

usb error ehci 1: qtd (0xefe180) error: 0x000d8d40

Can you try other ports/usb drives?

comment:21 by diver, 4 weeks ago

Probably a dupe of #5611.

Note: See TracTickets for help on using tickets.