Opened 10 months ago

Closed 10 months ago

Last modified 5 months ago

#15532 closed bug (fixed)

[scripting] Terminal crash when receiving some scripting messages

Reported by: X512 Owned by: jackburton
Priority: normal Milestone: R1/beta2
Component: Applications/Terminal Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

This is hrev53618 gcc2hybrid.

Steps to reproduce:

  1. Open Terminal
  2. Write "hey application/x-vnd.Haiku-Terminal GET View 0 of View 0 of View 0 of View 0 of View 1 of Window 0" in Pe.
  3. Press Alt+Enter when text caret is inside typed line.
  4. Terminal crash.

Attachments (1)

Terminal-640-debug-08-12-2019-17-33-40.report (38.2 KB ) - added by X512 10 months ago.
Debug report.

Download all attachments as: .zip

Change History (5)

by X512, 10 months ago

Debug report.

comment:2 by X512, 10 months ago

Bug seems to be fixed. Terminal scripting is working.

comment:3 by korli, 10 months ago

Resolution: fixed
Status: newclosed

Applied in hrev53634

comment:4 by nielx, 5 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.