Opened 12 years ago

Closed 2 years ago

#1555 closed bug (fixed)

[Deskbar] crash in DeleteMenuWindow

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

vm_soft_fault: va 0xa5 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0xa5, ip 0x360cb3, write 0, user 1, thread 0x1ad
vm_page_fault: sending team "/boot/beos/system/Deskbar" 0x49 SIGSEGV, ip 0x360cb3 ("libbe.so_seg0ro" +0x115cb3)
stack trace:
  0x003632ea (libbe.so_seg0ro + 0x1182ea)
  0x00362ccd (libbe.so_seg0ro + 0x117ccd)
  0x006c4ad0 (libroot.so_seg0ro + 0x20ad0)
  0x7003ffec (menu_tracking_1ad_stack + 0x3ffec)
vm_soft_fault: va 0x0 not covered by area in address space
vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x8009b92c, write 0, user 0, thread 0x1ad
debug_server: Thread 429 entered the debugger: Segment violation
stack trace, current PC 0x360cb3  _DeleteMenuWindow__5BMenu + 0x3b:
  (0x7003fedc)  0x3632ea  Track__8BMenuBarPllb + 0x59a
  (0x7003ff4c)  0x362ccd  TrackTask__8BMenuBarPv + 0x7d
  (0x7003ffac)  0x6c4ad0  _get_next_team_info + 0x5c (closest symbol)

Found with hrev22510 in vmware. Don't know how to reproduce it yet.

Change History (7)

comment:1 Changed 11 years ago by jackburton

Component: - Applications/DeskbarKits/Interface Kit
Owner: changed from axeld to jackburton

Did you find any way to reproduce this ? Since there have been many changes to BMenu tracking code since hrev22510, I'm for closing this bug. We can always reopen if it shows up again.

Objections ?

comment:2 Changed 11 years ago by diver

No, i didn't. Please close it, if i ever manage to reproduce it no one will stop me from reopening it again ;-) Oh, and while you are at here, please fix the wiki formatting (e.g. the {{{ stuff) in description.

comment:3 Changed 11 years ago by jackburton

Description: modified (diff)
Resolution: fixed
Status: newclosed

comment:4 Changed 7 years ago by diver

Component: Kits/Interface KitApplications/Deskbar
Description: modified (diff)
Resolution: fixed
Status: closedreopened
Version: R1/pre-alpha1R1/Development

This is hrev44053, gcc4hybrid.

This crash occured when I was trying to close Deskbar Applications menu by holding Esc key for a couple of seconds:

Thread 5543 caused an exception: Segment violation
[...]
[Switching to team /boot/system/Deskbar (135) thread menu_tracking (5543)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x00380aaf in BMenu::_DeleteMenuWindow () from /boot/system/lib/libbe.so
#2  0x003840c2 in BMenu::_Track () from /boot/system/lib/libbe.so
#3  0x003859f0 in BMenuBar::_Track () from /boot/system/lib/libbe.so
#4  0x00385f32 in BMenuBar::_TrackTask () from /boot/system/lib/libbe.so
#5  0x006b1247 in thread_entry () from /boot/system/lib/libroot.so
#6  0x78137fec in ?? ()
(gdb) 

vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x0, write 0, user 1, thread 0x15a7
vm_page_fault: thread "menu_tracking" (5543) in team "Deskbar" (135) tried to read address 0x0, ip 0x0 ("???" +0x0)
debug_server: Thread 5543 entered the debugger: Segment violation
stack trace, current PC (nil)  :
  (0x78137ddc)  0x3840c2  _ZN5BMenu6_TrackEPil + 0x610
  (0x78137eac)  0x3859f0  _ZN8BMenuBar6_TrackEPllb + 0x1e2
  (0x78137f5c)  0x385f32  _ZN8BMenuBar10_TrackTaskEPv + 0x74
  (0x78137fbc)  0x6b1247  thread_entry + 0x1d

comment:5 Changed 5 years ago by waddlesplash

Milestone: R1R1/alpha5

comment:6 Changed 5 years ago by mmadia

Milestone: R1/alpha5R1

No reason for this to delay the next release.

comment:7 Changed 2 years ago by diver

Resolution: fixed
Status: reopenedclosed

Likely fixed in the meantime.

Note: See TracTickets for help on using tickets.