Opened 22 months ago

Closed 20 months ago

Last modified 18 months ago

#15561 closed bug (fixed)

USB stop working after disconnecting USB hub with keyboard and mouse

Reported by: X512 Owned by: waddlesplash
Priority: normal Milestone: R1/beta2
Component: Drivers/USB/XHCI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

This is hrev53634 x86_64.

USB 2 hub with 4 ports is connected to USB 3 port of PC. Keyboard and mouse are connected to hub. If hub is disconnected and connected again, keyboard and mouse are no longer working. Mouse LED flashes and turn off.

syslog when hub is disconnected:

KERN: usb hub 2: port 2: device removed
KERN: usb xhci 0: cancel queued transfers (1) for pipe 0xffffffff82c00008 (1)
KERN: usb error xhci 0: cancel queued transfers: could not stop endpoint: Operation timed out!
KERN: usb xhci 0: KERN: usb xhci 0: usb xhci 0: KERN: cancel queued transfers (0) for pipe 0xffffffff82837100 (0)
KERN: transfer error on slot 5 endpoint 3: Stopped
KERN: cancel queued transfers (1) for pipe 0xffffffff82c00008 (1)
KERN: usb xhci 0: KERN: usb error xhci 0: KERN: cancel queued transfers (0) for pipe 0xffffffff82c00008 (1)
KERN: received command event for unknown command!
KERN: usb error xhci 0: unsuccessful command 15, error Context state (19)
KERN: usb xhci 0: cancel queued transfers (0) for pipe 0xffffffff82d79f60 (2)
KERN: usb error xhci 0: unsuccessful command 15, error Context state (19)
KERN: usb xhci 0: cancel queued transfers (1) for pipe 0xffffffff82c00058 (1)
KERN: usb error xhci 0: cancel queued transfers: could not stop endpoint: Operation timed out!
KERN: usb xhci 0: Mouse device exiting, Device not ready
KERN: usb xhci 0: KERN: cancel queued transfers (0) for pipe 0xffffffff82837180 (0)
KERN: transfer error on slot 4 endpoint 3: Stopped
KERN: usb xhci 0: Last message repeated 1 time
KERN: usb error xhci 0: cancel queued transfers (0) for pipe 0xffffffff82c00058 (1)
KERN: cancel queued transfers (0) for pipe 0xffffffff82c00058 (1)
KERN: received command event for unknown command!
KERN: usb error xhci 0: unsuccessful command 15, error Context state (19)
KERN: usb xhci 0: cancel queued transfers (1) for pipe 0xffffffff82c00eb8 (1)
KERN: usb error xhci 0: cancel queued transfers: could not stop endpoint: Operation timed out!
KERN: usb xhci 0: Last message repeated 1 time
KERN: cancel queued transfers (0) for pipe 0xffffffff82837300 (0)
KERN: transfer error on slot 1 endpoint 3: Stopped
KERN: usb error xhci 0: KERN: received command event for unknown command!
KERN: usb error xhci 0: KERN: unsuccessful command 10, error Slot not enabled (11)

syslog when hub is connected again:

KERN: usb hub 2: port 2: new device connected

Same problem can be caused by disconnecting USB device directly from PC, but effect is not reproduceable. I experieced similar problem with 32 bit USB 2 PC few years ago.

Attachments (2)

listdev.txt (2.4 KB ) - added by X512 22 months ago.
listdev
listusb.txt (17.4 KB ) - added by X512 22 months ago.
listusb

Download all attachments as: .zip

Change History (7)

by X512, 22 months ago

Attachment: listdev.txt added

listdev

by X512, 22 months ago

Attachment: listusb.txt added

listusb

comment:1 by waddlesplash, 22 months ago

Component: Drivers/USBDrivers/USB/XHCI
Owner: changed from mmlr to waddlesplash

comment:2 by waddlesplash, 22 months ago

I experieced similar problem with 32 bit USB 2 PC few years ago.

In this case, try waiting ~15-30 seconds before plugging the hub back in, and see if it makes any difference.

comment:3 by X512, 20 months ago

Seems fixed after hrev53884 on PC. I do not yet tried on tablet.

Last edited 20 months ago by X512 (previous) (diff)

comment:4 by waddlesplash, 20 months ago

Resolution: fixed
Status: newclosed

Excellent!

I did not change anything USB 2 related, so, that probably needs a separate ticket, if it is still a problem.

comment:5 by nielx, 18 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.