#15628 closed bug (fixed)

Distored Rendering of OS

Reported by: Paradoxon Owned by: pulkomandy
Priority: normal Milestone: R1/beta2
Component: Drivers/Graphics/intel_extreme/ironlake Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

since my update from hrev53658 to 53714 my display is distored i have the follwing controller device Display controller (VGA compatible controller, VGA controller) [3|0|0]

vendor 8086: Intel Corporation device 0046: Core Processor Integrated Graphics Controller

My Resolution ist 1366 x 768.

The display is kind of scaled (wrong aspect Ratio?) in the x - Axis ... this way that i cant acces the Deskbar anymore..

changing the resolution to 1024 x 768 kind of helped to display the Deskbar, but the aspectratio is still messed up...

Everything worked find before my update

Attachments (6)

syslog.distored (464.7 KB ) - added by Paradoxon 21 months ago.
syslog.crash_onworspaceswitch (13.9 KB ) - added by Paradoxon 21 months ago.
_20200118_211257.JPG (2.9 MB ) - added by Paradoxon 21 months ago.
Kdl with sc
_20200118_211623.JPG (463.7 KB ) - added by Paradoxon 21 months ago.
Distorded screen
syslog.crazy_lines (150.2 KB ) - added by Paradoxon 21 months ago.
_20200121_074713.JPG (275.4 KB ) - added by Paradoxon 21 months ago.

Change History (19)

comment:1 by diver, 21 months ago

Owner: set to pulkomandy
Status: newassigned

comment:2 by pulkomandy, 21 months ago

Please include syslogs before/after update.

by Paradoxon, 21 months ago

Attachment: syslog.distored added

comment:3 by pulkomandy, 21 months ago

Please try hrev53717 or later.

by Paradoxon, 21 months ago

comment:4 by Paradoxon, 21 months ago

Since hrev53717 on switch from 1024 x 768 (was my default now) to 1366 x 768. it was still scaled wrong (deskbar out of screen) on swith to a different workspace the screen turned black on switch to a nother workspace it showed crazy colored lines... and then it crashed (kerneldebuggerland... sady i didnt took a photo)

by Paradoxon, 21 months ago

Attachment: _20200118_211257.JPG added

Kdl with sc

by Paradoxon, 21 months ago

Attachment: _20200118_211623.JPG added

Distorded screen

comment:5 by pulkomandy, 21 months ago

This is not KDL but an app_server crash. You can type "save-report" from there to save a debug report.

comment:6 by pulkomandy, 21 months ago

Please try hrev53734 or later.

comment:7 by pulkomandy, 21 months ago

The part with the screen turning black:

intel_set_display_mode(14947x24936)

I fear this is something to be fixed in app_server side, if it gives us a mode like this, what should we do?

comment:8 by Paradoxon, 21 months ago

for your changes ... it rendered the system complete unusable.. :-D only flickering colored line (i can add a picture and syslog later since i have some trouble accesing them :))

by Paradoxon, 21 months ago

Attachment: syslog.crazy_lines added

by Paradoxon, 21 months ago

Attachment: _20200121_074713.JPG added

comment:9 by Paradoxon, 21 months ago

If you like i can try to write diffrent values to registers (guided over irc) ... in the kdl... if this helps you... (i dont have any knowledge there yet... but if it helps i can learn ;-))

comment:10 by pulkomandy, 21 months ago

Yes, the problem is it takes hours of checking and writing values in the registers even if I'm doing it directly sitting in front of the computer. I don't think doing it over IRC is reasonably practical :(

We should meet at some coding sprint or other event where I can borrow your computer and then I may be able to find the problem.

I will see if I can reproduce it here one one of my old laptops or borrow ones from other people around...

comment:11 by pulkomandy, 21 months ago

Ok, so today I noticed that I can reproduce the issue on my machine. So I will be able to investigate this. It is a newer generation but there is exactly the same problem.

The flickering colored lines are actually "better". What happened before is we were setting a broken video mode on the secondary display, but the LVDS panel was showing the primary one so this was not visible. Now, we set a broken mode on the primary display, and we can see what we are doing.

I will continue investigating this and fix the modesetting. I hope it will also help with other problems.

comment:12 by pulkomandy, 21 months ago

Milestone: UnscheduledR1/beta2

comment:13 by pulkomandy, 21 months ago

Resolution: fixed
Status: assignedclosed

Fixed (for real this time) in hrev53772.

Note: See TracTickets for help on using tickets.