Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#15829 closed bug (duplicate)

If HaikuDepot and/or SoftwareUpdater gets data from repositories the aforementioned programs stop working and crash themselves

Reported by: aidancuckoo Owned by: stippi
Priority: blocker Milestone:
Component: Applications/HaikuDepot Version: R1/beta1
Keywords: SoftwareUpdater, HaikuDepot Cc:
Blocked By: #15837 Blocking:
Platform: x86-64

Description

I have Haiku running on a VirtualBox VM and it keeps crashing when I open HaikuDepot for the second time for a machine - for some reason the first boot updates I do get through. From that point on, the bug "clings" onto SoftwareUpdater, affecting it too.

Change History (4)

comment:1 by diver, 2 years ago

Please attach debug report of the crashing apps. Also always mention Haiku revision.

comment:2 by apl-haiku, 2 years ago

It would also be helpful if you can look in the application's logs to get any diagnostic logs. To get those details, open a Terminal and issue the command;

/boot/system/apps/HaikuDepot -v trace > /tmp/log.txt

Have a look in the resultant /tmp/log.txt file and see if you can snip-out any diagnostic information and paste it here.

comment:3 by diver, 2 years ago

Blocked By: 15837 added
Resolution: duplicate
Status: newclosed

Probably a dupe of #15837.

comment:4 by nielx, 2 years ago

Milestone: Unscheduled

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.