Opened 11 years ago

Closed 11 years ago

#1585 closed bug (fixed)

Haiku doesn't boot with qemu

Reported by: jackburton Owned by: axeld
Priority: high Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Lately I'm forced to test haiku under qemu (it has been some time). I found out it doesn't boot. It locks up on the logo screen. Attached is the serial log output. This is under ubuntu 7.10 with qemu 0.9.0.

Attachments (2)

file.txt (24.4 KB) - added by jackburton 11 years ago.
Serial log
log.txt (23.8 KB) - added by jackburton 11 years ago.
hrev22975 serial log

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by jackburton

Attachment: file.txt added

Serial log

comment:1 Changed 11 years ago by stippi

Same here. In the meantime, you can boot Haiku in VMWare Player, which appears to be not supported by 7.10 at the moment, but when you download the player from the VMWare site, you can install it (run the install script with sudo and answer yes to pretty much everything) and it works fine and runs Haiku well.

comment:2 in reply to:  1 Changed 11 years ago by jackburton

Replying to stippi:

Same here. In the meantime, you can boot Haiku in VMWare Player, which appears to be not supported by 7.10 at the moment,

Yeah, that's basically why I switched to qemu :)

but when you download the player from the VMWare site, you can install it (run the install script with sudo and answer yes to pretty much everything) and it works fine and runs Haiku well.

Yeah I've read about this solution, thank you. But being a lazy man, I'd prefer the "ready" package :). I hoped they provided it earlier, though... sigh, I guess I'll have to dowload the player from the official site...

comment:3 Changed 11 years ago by axeld

I can reproduce the problem here as well; it seems to be the same bug that makes "sync" problematic in VMware, so I guess Qemu has improved/changed its IDE emulation. In any way, it boots fine when you turn off IDE DMA in the boot menu. HTH until it gets fixed :-)

comment:4 in reply to:  3 Changed 11 years ago by jackburton

Replying to axeld:

I can reproduce the problem here as well; it seems to be the same bug that makes "sync" problematic in VMware, so I guess Qemu has improved/changed its IDE emulation. In any way, it boots fine when you turn off IDE DMA in the boot menu. HTH until it gets fixed :-)

That works, indeed. Weird, I was sure I checked all the items in the safe boot menu...

comment:5 Changed 11 years ago by mmlr

It works on a win32 QEMU (at work) and an image from the build factory (hrev22728). I think this is a GCC4 build, maybe this has an influence?

comment:6 in reply to:  5 Changed 11 years ago by jackburton

Replying to mmlr:

It works on a win32 QEMU (at work) and an image from the build factory (hrev22728). I think this is a GCC4 build, maybe this has an influence?

Did you use qemu 0.9.0 or another version ?

BTW I hoped this was fixed by Ingo in hrev22975 but it's not the case. So it's probably unrelated to #985.

Changed 11 years ago by jackburton

Attachment: log.txt added

hrev22975 serial log

comment:7 Changed 11 years ago by jackburton

Resolution: fixed
Status: newclosed

Works fine with hrev23162.

Note: See TracTickets for help on using tickets.