Opened 11 months ago

Closed 11 months ago

Last modified 11 months ago

#16000 closed bug (duplicate)

Deskbar crash (reproducible)

Reported by: un_spacyar Owned by: jscipione
Priority: normal Milestone: Unscheduled
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: #15991 Blocking:
Platform: All

Description (last modified by un_spacyar)

Hello. I found a way to crash Deskbar.I had open Otter browser, with the Otter scrollbar next to the Deskbar (see attached image).

When grab and move the scrollbar (not by the arrows, but by the slider), and continue the mouse movement over the Deskbar (click without release, like trying to drop the slider over the Deskbar), the Deskbar crash. (crash report attached too).

The weird things:

  • Apparently, not happends in all the apps. I found the error using Otter.
  • Also, not happends in all the Otter windows. I found it can be reproducible browsing this page:

https://www.haiku-os.org/legacy-docs/benewsletter/index.html

  • Maybe is related to the slider size?
  • The first time that Deskbar crashed, I also get a launch-daemon crash. After this crash, I had to reboot. In the following cases, only Deskbar crashed. In any case, I also attach the launch-daemon crash report.

now the facts: Haiku hrev54142 (x86_gcc2)

Attachments (3)

Deskbar-499-debug-09-05-2020-14-22-50.report (15.7 KB ) - added by un_spacyar 11 months ago.
Deskbar crash report.
launch_daemon-445-debug-09-05-2020-14-23-00.report (9.7 KB ) - added by un_spacyar 11 months ago.
launch-daemon crash report
Deskbar_Crash_Otter_and_Deskbar_1.png (103.9 KB ) - added by un_spacyar 11 months ago.
Otter and Deskbar position

Download all attachments as: .zip

Change History (10)

by un_spacyar, 11 months ago

Deskbar crash report.

by un_spacyar, 11 months ago

launch-daemon crash report

comment:1 by X512, 11 months ago

Deskbar-499-debug-09-05-2020-14-22-50.report​

Duplicate of #15991.

by un_spacyar, 11 months ago

Otter and Deskbar position

comment:2 by un_spacyar, 11 months ago

Description: modified (diff)

comment:3 by un_spacyar, 11 months ago

X512, thanks for the fast answer! :)

I will test it again in hrev54159 when it be available in HaikuDepot.

comment:4 by pulkomandy, 11 months ago

Blocked By: 15991 added
Resolution: duplicate
Status: newclosed

comment:5 by pulkomandy, 11 months ago

Congratulation on crating bug #16000 however :)

comment:6 by mmlr, 11 months ago

What about the launch_daemon crash? It looks like memory corruption happened. Deskbar going away would trigger launch_daemon to relaunch it, so there may be corruption in the relaunch path (or earlier, and it is just the one stumbling over it). To investigate, launch_daemon should be run under the guarded heap.

in reply to:  6 comment:7 by mmlr, 11 months ago

Replying to mmlr:

What about the launch_daemon crash?

I was unable to reproduce the launch_daemon crash under the guarded heap.

Was there anything special going on with the launch_daemon? Did you interact with it using launch_roster or something like that?

Note: See TracTickets for help on using tickets.