#16047 closed bug (duplicate)

Test build 2020-05: boot loader does not find usb drive

Reported by: cucujoidea Owned by:
Priority: normal Milestone: Unscheduled
Component: System/Boot Loader/BIOS Version: R1/Development
Keywords: Cc:
Blocked By: #14490 Blocking:
Platform: All

Description

The 64 Bit version of Haiku, hrev54154 was taken from https://discuss.haiku-os.org/t/help-wanted-r1-beta2-boot-hardware-testing/9511 . dd to a 8 GB USB 2 stick. The boot loader shows up, but then it does not find the drive (see screenshot).

Attachments (9)

Haiku_beta2_test_cucu_bootproblem.jpg (97.4 KB ) - added by cucujoidea 11 months ago.
Bootloader does not find its drive
Haiku_beta2_test_cucu_bootproblem_1_k.jpg (165.3 KB ) - added by cucujoidea 11 months ago.
Haiku_beta2_test_cucu_bootproblem_2_k.jpg (186.6 KB ) - added by cucujoidea 11 months ago.
Haiku_beta2_test_cucu_bootproblem_3_k.jpg (142.8 KB ) - added by cucujoidea 11 months ago.
Haiku_beta2_test_cucu_bootproblem_4_k.jpg (118.8 KB ) - added by cucujoidea 11 months ago.
Haiku_beta2_test_cucu_bootproblem_6_k.jpg (203.2 KB ) - added by cucujoidea 11 months ago.
Haiku_beta2_test_cucu_bootproblem_7_k.jpg (200.6 KB ) - added by cucujoidea 11 months ago.
Haiku_beta2_test_cucu_bootproblem_8_k.jpg (203.1 KB ) - added by cucujoidea 11 months ago.
Haiku_beta2_test_cucu_bootproblem_9_k.jpg (204.1 KB ) - added by cucujoidea 11 months ago.

Download all attachments as: .zip

Change History (17)

by cucujoidea, 11 months ago

Bootloader does not find its drive

comment:1 by waddlesplash, 11 months ago

Is this truly the BIOS loader, or the EFI loader?

Can you please get a snapshot of the bootloader log, in the debug menu?

comment:2 by cucujoidea, 11 months ago

The CPU is the same as in my other Ticket #14490

comment:3 by waddlesplash, 11 months ago

reading 4 bytes from drive 128 failed at 299116

That sounds like the problem here.

comment:4 by cucujoidea, 11 months ago

Thanks for looking into this. Please let me know if you need further information (such as finding the version which worked last).

comment:5 by waddlesplash, 11 months ago

If you know it worked before, yes, testing older versions to see if you can find one where it does work would help.

comment:6 by cucujoidea, 11 months ago

(The problem is there also with beta1) When i turn RAID Mode in the BIOS from AHCI to IDE (and enable serial logging), it boots to the desktop.

comment:7 by cucujoidea, 11 months ago

i guess this is mostly a double of Ticket #14490 since with my current system both haiku-r1beta1-hrev52295 and https://discuss.haiku-os.org/t/help-wanted-r1-beta2-boot-hardware-testing/9511 ( hrev54154 ) only get to the boot menue.

comment:8 by waddlesplash, 11 months ago

Blocked By: 14490 added
Platform: x86-64All
Resolution: duplicate
Status: newclosed

If not even the BIOS can read from the device, your BIOS may just be plain broken.

Note: See TracTickets for help on using tickets.