Opened 12 years ago

Closed 12 years ago

#1606 closed bug (fixed)

"controller doesn't implement any ports" with ICH6M

Reported by: pfoetchen Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc: marcusoverhagen
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When i boot on my laptop I get the following error in rev 22849 :

PANIC: vm_page_fault: unhandled page fault in kernel space at 0x31, ip 0x802b47b9

here is the output of lspci under linux: 00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03) 00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root Port (rev 03) 00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03) 00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03) 00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03) 00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03) 00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03) 00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03) 00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3) 00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03) 00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03) 00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03) 00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03) 01:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce Go 6200/6400] (rev a1) 06:05.0 CardBus bridge: Texas Instruments PCI7420 CardBus Controller 06:05.2 FireWire (IEEE 1394): Texas Instruments PCI7x20 1394a-2000 OHCI Two-Port PHY/Link-Layer Controller 06:05.3 Mass storage controller: Texas Instruments PCI7420/7620 Combo CardBus, 1394a-2000 OHCI and SD/MS-Pro Controller 06:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile (rev 03) 06:0b.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

Attachments (2)

bt.jpg (220.2 KB) - added by pfoetchen 12 years ago.
output of bt
safe mode.jpg (225.8 KB) - added by pfoetchen 12 years ago.
output safe mode

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by pfoetchen

Attachment: bt.jpg added

output of bt

comment:1 Changed 12 years ago by pfoetchen

this could be a duplicate of #1578 the back trace is almost the same..but #1578 was fixed....

comment:2 Changed 12 years ago by pfoetchen

i tried booting in safe mode and it complains that an entry allready exists for the ahci controler... so it realy seems to be related to #1578....

Changed 12 years ago by pfoetchen

Attachment: safe mode.jpg added

output safe mode

comment:3 Changed 12 years ago by marcusoverhagen

Cc: marcusoverhagen added

Does it still complain that an object for the device already exists? What revision are you using?

comment:4 Changed 12 years ago by pfoetchen

I used rev 22849 for the screenshots. With rev 22888 it still complains about existing device. But it could be the correct behavior since it complained about not finding the boot device ( I told the debugger to continue) and rescanned the busses. But I still get the page fault. The interresting thing is that if I only enable text output but not the safe mode it complains about not finding the boot device but does not bring the page fault ( it just hangs after not finding init) When I boot normaly I don't the boot device not found thing but only the page fault...

comment:5 Changed 12 years ago by pfoetchen

I changed the partition type to BeOs and set the boot flag and installed a newer version... Now I get the boot device not found error on normal boot but no page fault anymore.... So it could be that the bug is fixed in rev 22927 ( or setting the partition type an boot flag has fixed it??? ) I still have the Problem that it does not recognize my boot disk.... I will some stuff and report back later...

comment:6 Changed 12 years ago by pfoetchen

I found out that the existing device error only happens when haiku rescanns the busses

comment:7 Changed 12 years ago by pfoetchen

I slowed down the console output and I got "controller doesn't implement any ports"...

comment:8 Changed 12 years ago by pfoetchen

Summary: Kernel Panic at boot"controller doesn't implement any ports" with ICH6M

ok I "forced" the driver to have 4 ports ( linux does the same thing in it's driver) but it still doesn't find the hd ...

here is the output of the linux driver I hope it helps a bit..

ahci 0000:00:1f.2: version 2.2
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 10
ACPI: PCI Interrupt 0000:00:1f.2[B] -> Link [LNKC] -> GSI 10 (level, low) -> IRQ 10
ahci 0000:00:1f.2: PORTS_IMPL is zero, forcing 0xf
ahci 0000:00:1f.2: AHCI 0001.0000 32 slots 4 ports 1.5 Gbps 0xf impl IDE mode
ahci 0000:00:1f.2: flags: 64bit ncq pm led pmp slum part
PCI: Setting latency timer of device 0000:00:1f.2 to 64
scsi0 : ahci
PM: Adding info for No Bus:host0
scsi1 : ahci
PM: Adding info for No Bus:host1
scsi2 : ahci
PM: Adding info for No Bus:host2
scsi3 : ahci
PM: Adding info for No Bus:host3
ata1: SATA max UDMA/133 cmd 0xe0820500 ctl 0x00000000 bmdma 0x00000000 irq 10
ata2: SATA max UDMA/133 cmd 0xe0820580 ctl 0x00000000 bmdma 0x00000000 irq 10
ata3: SATA max UDMA/133 cmd 0xe0820600 ctl 0x00000000 bmdma 0x00000000 irq 10
ata4: SATA max UDMA/133 cmd 0xe0820680 ctl 0x00000000 bmdma 0x00000000 irq 10
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: ATA-6: HTS541060G9SA00, MB3OC40J, max UDMA/100
ata1.00: 117210240 sectors, multi 0: LBA48
ata1.00: configured for UDMA/100
ata2: SATA link down (SStatus 0 SControl 0)
ata3: SATA link down (SStatus 0 SControl 300)
ata4: SATA link down (SStatus 0 SControl 0)
PM: Adding info for No Bus:target0:0:0
scsi 0:0:0:0: Direct-Access     ATA      HTS541060G9SA00  MB3O PQ: 0 ANSI: 5
PM: Adding info for scsi:0:0:0:0
sd 0:0:0:0: [sda] 117210240 512-byte hardware sectors (60012 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sd 0:0:0:0: [sda] 117210240 512-byte hardware sectors (60012 MB)
sd 0:0:0:0: [sda] Write Protect is off
sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
 sda: sda1 sda2 sda3 sda4
sd 0:0:0:0: [sda] Attached SCSI disk
sd 0:0:0:0: Attached scsi generic sg0 type 0

I will try to do some screenshots during boot. And compare the linux and the haiku driver a bit more...

comment:9 Changed 12 years ago by marcusoverhagen

Resolution: fixed
Status: newclosed

The "controller doesn't implement any ports" should be fixed with hrev22959. The panic during boot has the same cause as #1578, which I just reopened as I've seen it again, too.

Note: See TracTickets for help on using tickets.