Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#161 closed bug (fixed)

BTextControl bug

Reported by: diver Owned by: jackburton
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Test Case: open Expander -> Edit -> Preferences -> select /boot/home as extract path via File Panel -> press ok -> Edit -> Preferences -> select /boot/home/config as extract path and it will still show /boot/home/, but selecting path by mouse in Use: field textcontrol will show that there are some hidden symbols now. Also seen kinda same sort of bug in R5's MineSweeper under Haiku: To reproduce it - win 1 game and it will show you a window where you should put you name. There would be smth wrong with that textcontrol too.

Attachments (1)

BTextControl.PNG (36.0 KB ) - added by diver 14 years ago.
BTextControl bug

Download all attachments as: .zip

Change History (19)

by diver, 14 years ago

Attachment: BTextControl.PNG added

BTextControl bug

comment:1 by jackburton, 14 years ago

Owner: changed from bpmagic@… to jackburton

comment:2 by jackburton, 14 years ago

Can't reproduce. Maybe it's been fixed already in the meantime. I'll close the bug, unless someone reports it again.

comment:3 by korli, 14 years ago

Is it still valid and reproducible ?

comment:4 by diver, 14 years ago

Yes it is, at least in rev16475 under vmware. Another test case (easyer): Launch Tracker. Check "Show navigator" option in Tracker settings. Go to /boot/beos/system/add-ons Look at the path in Navigator, it will be truncated to /boot/beos/system

comment:5 by jackburton, 14 years ago

Status: newassigned

comment:6 by jackburton, 14 years ago

I can reproduce it that way. Thanks.

comment:7 by jackburton, 14 years ago

Status: assignedclosed

comment:8 by jackburton, 14 years ago

Fixed in 16485

comment:9 by jackburton, 14 years ago

Resolution: fixed

comment:10 by jackburton, 14 years ago

Status: closedreopened

comment:11 by jackburton, 14 years ago

Happens again, probably related to my recent implementation of BTextView::AutoResize(). Will have a look as soon as possible.

comment:12 by jackburton, 14 years ago

Resolution: fixed

comment:13 by jackburton, 14 years ago

* Bug 283 has been marked as a duplicate of this bug. *

comment:14 by jackburton, 14 years ago

Cc: darkwyrm@… added

comment:15 by jackburton, 14 years ago

I fixed it in my local tree. Will commit in the next days.

comment:16 by jackburton, 14 years ago

Status: reopenedclosed

comment:17 by jackburton, 14 years ago

Fixed in rev. 16770, but might need more work.

comment:18 by jackburton, 14 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.