Opened 3 years ago

Last modified 3 years ago

#16142 new bug

Locale: Inaccurate Defaults button behaviour

Reported by: bitigchi Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Preferences/Locale Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

Currently Defaults button in Locale preflet changes everything back to English and English locale settings. This can be defined as inaccurate, because user sets this info for once in FirstBootPrompt, and these settings should be counted as the default. Changing everything back to pre-install settings is undesirable in this case.

On the other hand, Revert button seems to function enough in this case. After setting the locale during install, if the user changes a setting by mistake, he/she can revert to the intended settings with this button.

As I see, there are two possible solutions to this:

  • Have FirstBootPrompt create a separate defaults configuration, and have Defaults button refer to these settings
  • Remove Defaults button, and keep Revert. I am not sure if this covers all cases, but at the moment seems sufficient enough.

Change History (2)

comment:1 by humdinger, 3 years ago

Have FirstBootPrompt create a separate defaults configuration, and have Defaults button refer to these settings

This makes sense IMO. If there's no FirstBootPrompt settings (maybe an image was dd'ed directly) Locale can just reset to English.

comment:2 by pulkomandy, 3 years ago

Should "defaults" change the language at all? Is that really useful?

Note: See TracTickets for help on using tickets.