Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#16216 closed bug (fixed)

Some icons missing in HaikuDepot

Reported by: humdinger Owned by: apl-haiku
Priority: normal Milestone: R1/beta3
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

This is on the RC2 of R1/beta2, 32bit (hrev54154+110).

When opening HaikuDepot, the lists of packages are populated alright. Some packages' custom icons are missing, however, sowing the default HPKG icon instead. Refreshing repos from inside HaikuDepot doesn't change that.
For example, from the "Recommended" tab, it's Arduino, BeShare, Calligra Suite, DocumentViewer, DosBox, Flare, KeePassXC...

I removed ~/config/cache/HaikuDepot and ~/config/settings/HaikuDepot and started from Terminal with "HaikuDepot -v trace". The output is attached as HD-trace.txt.

Selecting an app does load ratings and screenshots, but the icon still isn't updated. The output when selecting Koder is attached as Koder-selected.txt.

I don't know if this is a HaikuDepot app failure, or if HDS or some service inbetween is to blame.

Attachments (4)

HD-trace.txt (671.8 KB ) - added by humdinger 2 years ago.
Launching HaikuDepot traced
Koder-selected.txt (3.1 KB ) - added by humdinger 2 years ago.
Output when Koder is selected
log-beta2-rc2.txt (1.3 MB ) - added by humdinger 2 years ago.
Log of beta2/rc2
log-nightly-hrev54302.txt (1.3 MB ) - added by humdinger 2 years ago.
Log of nightly hrev54302

Change History (14)

by humdinger, 2 years ago

Attachment: HD-trace.txt added

Launching HaikuDepot traced

by humdinger, 2 years ago

Attachment: Koder-selected.txt added

Output when Koder is selected

comment:1 by apl-haiku, 2 years ago

I am not on the R1B2 candidate, but I can currently see all of the icons appearing properly on the nightly. Do you see this same problem on the nightly or a recent build off master?

I think the trace you have supplied is cropped unfortunately; would you be able to pipe it to a file and then supply that file.

HaikuDepot -v trace > /tmp/log.txt 2>&1

Also, as a diagnostic, the icons are currently unpacked onto the file system (I am going to change that in the future) and so you should be able to find the icon here;

~/config/cache/HaikuDepot/__allicons/hicn/koder

There you should find a single icon.hvif file. Can you see it?

comment:2 by apl-haiku, 2 years ago

I just downloaded the R1B2 candidate hrev54154+110 and the icons all seem to be appearing correctly including for the Koder package? Can somebody else verify the issue.

comment:3 by humdinger, 2 years ago

Attached the uncropped logs from beta2/rc2 and a current nightly (hrev54302). Both beta2/rc2 and the nightly image show the same issue. The Koder icon is present at ~/config/cache/HaikuDepot/allicons/hicn/koder. checkfs -c /boot returns a clean report, fwiw.

by humdinger, 2 years ago

Attachment: log-beta2-rc2.txt added

Log of beta2/rc2

by humdinger, 2 years ago

Attachment: log-nightly-hrev54302.txt added

Log of nightly hrev54302

comment:4 by diver, 2 years ago

Unable to reproduce on 64bit Haiku. Will try with 32bit.

comment:5 by apl-haiku, 2 years ago

I see...

[ServerIconExportUpdateProcess] did not set the package icon for [koder_x86]; no data

It's the old _x86 rearing it's head again. OK I will see what I can do with a work-around for the special suffix.

comment:6 by apl-haiku, 2 years ago

The fix for this issue will be in HDS rather than in the desktop client, but this ticket remains open here since it will need to be checked in the desktop client.

comment:7 by apl-haiku, 2 years ago

I forgot to mention this should be resolved now -- can you please check this one again?

comment:8 by humdinger, 2 years ago

Resolution: fixed
Status: newclosed

It's working indeed (after I cleaned out the cache). Thank you very much!

comment:9 by apl-haiku, 2 years ago

OK cool; people's caches should be refreshed when there are new icons to be pulled down.

comment:10 by pulkomandy, 2 years ago

Milestone: UnscheduledR1/beta3

Move closed tickets into beta3 milestone

Note: See TracTickets for help on using tickets.