Opened 9 months ago

Closed 9 months ago

#16374 closed bug (fixed)

Icon-O-Matic - crashing on launch

Reported by: vidrep Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: Applications/Icon-O-Matic Version: R1/beta2
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

Updated from hrev54396 to hrev54402 Icon-O-Matic now crashing Debugger report and .iom file attached

Attachments (4)

Web+New.iom (56.5 KB ) - added by vidrep 9 months ago.
Icon-O-Matic-2754-debug-06-07-2020-23-47-55.report (13.7 KB ) - added by vidrep 9 months ago.
Icon-O-Matic (319 bytes ) - added by vidrep 9 months ago.
Icon-O-Matic-1080-debug-07-07-2020-16-24-21.report (12.0 KB ) - added by vidrep 9 months ago.

Download all attachments as: .zip

Change History (11)

by vidrep, 9 months ago

Attachment: Web+New.iom added

comment:1 by waddlesplash, 9 months ago

I can't reproduce this with the attached .iom and a rebuilt Icon-O-Matic plus rebuilt libbe with the changes from the new hrev, on 32bit at least. Maybe it's somehow 64-bit specific?

comment:2 by mmlr, 9 months ago

As this comes from _RestoreSettings, this is probably specific to what the settings file contains. Can you attach the Icon-O-Matic settings from /boot/home/config/settings?

by vidrep, 9 months ago

Attachment: Icon-O-Matic added

comment:3 by vidrep, 9 months ago

Settings file attached

comment:4 by vidrep, 9 months ago

Deleting the settings file allows me to open the .iom file with Icon-O-Matic, but it will crash again when closing the app. Debugger report from crash on close attached.

in reply to:  4 comment:5 by roiredxsoto, 9 months ago

Replying to vidrep:

Deleting the settings file allows me to open the .iom file with Icon-O-Matic, but it will crash again when closing the app. Debugger report from crash on close attached.

Good day, Confirmed here on 64bit. Deleting the settings file allows Icon-O-Matic to launch, it does crash when closing, saving or "saving as".

Regards, RR

comment:6 by roiredxsoto, 9 months ago

Good day,

It seems to be fixed on hrev54473. Now Icon-O-Matic closes, without the crash, also allows to save the Icon file, and also "save as".

So I presume this can be closed too.

Regards,
RR

comment:7 by waddlesplash, 9 months ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.