Opened 18 months ago

Closed 7 weeks ago

#16413 closed bug (fixed)

Unable to change refresh rate setting (Hz) under "Screen", under preferences.

Reported by: mpxlbs Owned by: nobody
Priority: normal Milestone: R1/beta4
Component: Drivers Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86-64

Description (last modified by mpxlbs)

Carefully submitting this ticket. I don't know if it's a Vesa/Framebuffer limitation/invalid ticket.

Trying to select a new refresh rate under screen other than 60hz results in

"The screen mode could not be set: Invalid argument"

My display supports up to 144hz and uses displayport 1.2 to and from the GPU.

hrev54429

Attachments (1)

syslog (232.1 KB ) - added by mpxlbs 18 months ago.
Syslog July 17th

Download all attachments as: .zip

Change History (7)

comment:1 by mpxlbs, 18 months ago

Description: modified (diff)

comment:2 by waddlesplash, 18 months ago

Please attach a syslog.

by mpxlbs, 18 months ago

Attachment: syslog added

Syslog July 17th

comment:3 by maquak, 10 months ago

I can reproduce this problem. In fact refresh setting is the only parameter that I can change as there are only 2 modes detected for my display: resolution and color modes are constant (1920x1080x32) and I have 2 refresh rates available.

I've managed to debug that it's a status code returned from BScreen API. I want to look closer as my first task.

comment:4 by maquak, 10 months ago

After studying how it all works, my understanding is that I'm using UEFI and Haiku basically is using fixed screen mode set by bootloader and there are no services in UEFI that would allow to change it after OS boots, so a dedicated graphics driver would be required to change mode.

I confirmed that B_BAD_VALUE is returned in my case here: https://git.haiku-os.org/haiku/tree/src/add-ons/accelerants/vesa/mode.cpp#n201

Action points:

  1. Change return code here to B_UNSUPPORTED, so that error message shown to user makes more sense.
  2. Investigate why screenmode -l shows 2 supported modes - I would expect only 1 if I can't change it.
  3. Modify Screen preferences app to show just 1 refresh rate - currently it shows multiple refresh rates available to choose.

comment:5 by mpxlbs, 9 months ago

Great work guys, the option to set HZ has been removed when using the vesa driver! No more confusion :)

Edit: Although, it is still present when using "Framebuffer", instead of "Vesa", under "Screen", it now reports as "Operation not supported". Good work!

Last edited 9 months ago by mpxlbs (previous) (diff)

comment:6 by diver, 7 weeks ago

Milestone: UnscheduledR1/beta4
Resolution: fixed
Status: newclosed

Seems to be fixed then.

Note: See TracTickets for help on using tickets.