Opened 9 months ago

Closed 9 months ago

Last modified 7 months ago

#16433 closed bug (fixed)

Can't build haiku-nightly.iso

Reported by: greekboy Owned by: pulkomandy
Priority: normal Milestone:
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

When I run the command jam -q -j4 @nightly-cd I have error, see the log.

When I run the command jam -q -j4 @nightly-anyboot

I have no problem.

I think the problen is in the hrev54449

Attachments (1)

log.txt (7.9 KB ) - added by greekboy 9 months ago.

Download all attachments as: .zip

Change History (13)

by greekboy, 9 months ago

Attachment: log.txt added

comment:1 by waddlesplash, 9 months ago

Component: SystemBuild System
Owner: changed from nobody to pulkomandy
Status: newassigned

comment:2 by pulkomandy, 9 months ago

I don't see how this change can cause it? It should only cause mkindex to *not* be run in some cases.

Do you have a previous revision you know worked in your setup? Which one was it?

comment:3 by diver, 9 months ago

What is your host system?

comment:4 by greekboy, 9 months ago

My system is Ubuntu 20.04

The last successfuly build is 6 days before.

Look my topic https://discuss.haiku-os.org/t/cant-build-release-anyboot-for-x86-gcc2-hybrid/9811

comment:5 by greekboy, 9 months ago

I think the last successfully compile is with hrev54429.

comment:6 by pulkomandy, 9 months ago

Ok, in that case the problem might be in hrev54437

comment:7 by pulkomandy, 9 months ago

Do we still allow the plain CD profile? Anyboot is fine for burning on CDs as well. Well I'll try to fix it, but just use anyboot.

Also, I don't reproduce the issue here on my Linux machine. I get errors from basename about an invalid option however.

Last edited 9 months ago by pulkomandy (previous) (diff)

comment:8 by pulkomandy, 9 months ago

Should work again in hrev54458

comment:9 by greekboy, 9 months ago

Now is fine! Everything works perfectly.

Please close the ticket.

comment:10 by pulkomandy, 9 months ago

Resolution: fixed
Status: assignedclosed

comment:11 by nielx, 7 months ago

Milestone: UnscheduledR1/beta3

Assign fix to milestone:R1/beta3, as it looks like this fix will be part of that release.

As we started with the previous beta, we would like to use the Milestone field for fixed tickets to log from which release the improvement will be out. Therefore it is very much appreciated to assign the milestone when closing a ticket as fixed.

comment:12 by nielx, 7 months ago

Milestone: R1/beta3

Reverting ticket update, it seems to be a fix to a regression added _after_ milestone:R1/beta2, so it would be incorrect to add this to the list of fixes in milestone:R1/beta3.

My apologies for the noise.

Note: See TracTickets for help on using tickets.