Opened 12 years ago

Closed 11 years ago

#1669 closed bug (fixed)

Fails on boot

Reported by: artemm Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

System: Acer Aspire3683WXMi Intel Celeron M 430 ide controller: Intel 82801GBM/GHM (ICH7 Family) SATA IDE Controller (27c4) graphics controller: Intel Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (27a2, 27a6)

Haiku installed by JAM on First Logical partition of Extended Partition

the first fail is like in #1655 ticket if it passed with 'Use fail-safe video mode' option there is next problem.

PANIC:  get_boot_partitions failed!
Welcome to Kernel Debugging Land...
Running on CPU 0
kdebug>sc
stack trace for thrwad 0x7 "main2"
    kernel stock: 0x80148000 to 0x8014c000
frame            caller     <image>:function + offset
8014bad4 (+  52) 8007b31c   <kernel>:invoke_command + 0x0074
8014bb08 (+  48) 8007b43a   <kernel>:kernel_debugger + 0x00de
8014bb38 (+  32) 8007bf0e   <kernel>:kernel_debugger + 0x00b6
8014bb58 (+ 192) 8007be4d   <kernel>:panic + 0x0029
8014bc18 (+ 816) 8004c6d5   <kernel>:vfs_mount_boot_file_system + 0x0045
8014bf48 (+ 144) 800259f9   <kernel>:main2 + 0x00d1
8014bfd8 (+  32) 8003442b   <kernel>:_create_kernel_thread_kentry__Fv + 0x001b
8014bff8 (+2146123784) 800343c0   <kernel>:thread_kthread_exit__Fv + 0x0000

with screen debug output option

PANIC:  get_boot_partitions failed!
Welcome to Kernel Debugging Land...
Running on CPU 0
kdebug>


ahci: ahci_get_supported_path
        found isa!!
        found dfiver/dev/disk/ide!!
        add module busses/ide/ide_isa/device_v1 to list
has connection? yes
module: busses/ide/ide_isa/device_v1, support: 0.6
INIT: main: done... begin idle loop on cpu 0
tried best module: busses/ide/ide_isa/device_v1: No error
KdiskDeviceManager::InitialDeviceScan() failed: No such file or directory

Attachments (8)

haiku_dbg.part1.rar (488.3 KB) - added by artemm 12 years ago.
Debug pages screenshots part1
haiku_dbg.part2.rar (488.3 KB) - added by artemm 12 years ago.
Debug pages screenshots part2
haiku_dbg.part3.rar (488.3 KB) - added by artemm 12 years ago.
Debug pages screenshots part3
haiku_dbg.part4.rar (488.3 KB) - added by artemm 12 years ago.
Debug pages screenshots part4
haiku_dbg.part5.rar (488.3 KB) - added by artemm 12 years ago.
Debug pages screenshots part5
haiku_dbg.part6.rar (488.3 KB) - added by artemm 12 years ago.
Debug pages screenshots part6
haiku_dbg.part7.rar (488.3 KB) - added by artemm 12 years ago.
Debug pages screenshots part7
haiku_dbg.part8.rar (335.1 KB) - added by artemm 12 years ago.
Debug pages screenshots part8

Change History (20)

comment:1 Changed 12 years ago by artemm

is it not a bug???

comment:2 Changed 12 years ago by axeld

Owner: changed from axeld to marcusoverhagen

comment:3 Changed 12 years ago by artemm

mooved Haiku to primary partition but it still fails...

comment:4 Changed 12 years ago by marcusoverhagen

Status: newassigned

I assume you can't provide serial debug output.

Is this a single non-SATA harddisk in a notebook? How many partitions?

comment:5 in reply to:  4 Changed 12 years ago by artemm

yes you're right there is no serial port

it's a notebook ide controller:Intel 82801GBM/GHM (ICH7 Family) SATA IDE Controller (8086_27c4) single hdd: Hitachi Travelstar 5K160 80GB SATA (HTS541680J9SA00)

there are 3 primary partitions + 1 Extended with 2 logical partitions | pri. Haiku | pri. NTFS | pri. NTFS | ext. | log. LinuxExt3 | log. LinuxSwap |

comment:6 Changed 12 years ago by artemm

any idea?

comment:7 Changed 12 years ago by marcusoverhagen

I added more debugging output to the IDE driver, both PCI and ISA, in hrev23142.

Please apply the blue_screen.diff patch from bug report #1444, it makes console debug output pause after ech full page, and make photos using hrev23142 or later.

Changed 12 years ago by artemm

Attachment: haiku_dbg.part1.rar added

Debug pages screenshots part1

Changed 12 years ago by artemm

Attachment: haiku_dbg.part2.rar added

Debug pages screenshots part2

Changed 12 years ago by artemm

Attachment: haiku_dbg.part3.rar added

Debug pages screenshots part3

Changed 12 years ago by artemm

Attachment: haiku_dbg.part4.rar added

Debug pages screenshots part4

Changed 12 years ago by artemm

Attachment: haiku_dbg.part5.rar added

Debug pages screenshots part5

Changed 12 years ago by artemm

Attachment: haiku_dbg.part6.rar added

Debug pages screenshots part6

Changed 12 years ago by artemm

Attachment: haiku_dbg.part7.rar added

Debug pages screenshots part7

Changed 12 years ago by artemm

Attachment: haiku_dbg.part8.rar added

Debug pages screenshots part8

comment:8 Changed 12 years ago by artemm

ok. the latest revision solves the problem! thanks!

but i think there is a time to open a new ticket... when i get "INIT: Bootscript started" debugging console message, my machine completely hangs.

comment:9 Changed 12 years ago by artemm

close ticket.

i've fixed "bootscript" problem.

comment:10 Changed 11 years ago by korli

Marcus, can we close the ticket ?

comment:11 Changed 11 years ago by diver

This bug seems to be fixed.

comment:12 Changed 11 years ago by jackburton

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.