Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#16698 closed bug (fixed)

Removing multiple selected playlist items only affects one item

Reported by: jadedctrl Owned by: stippi
Priority: normal Milestone: R1/beta3
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86-64

Description

If you select multiple items in the playlist (alt+a or shift-click) and try to remove them, only the first-selected item is deleted.

I can replicate it on two 64-bit installs at hrev54812.

Attachments (2)

pre-remove.png (22.0 KB ) - added by jadedctrl 4 months ago.
How items are selected before trying to remove them
post-remove.png (21.4 KB ) - added by jadedctrl 4 months ago.
How the playlist looks after trying to remove multiple items

Download all attachments as: .zip

Change History (5)

by jadedctrl, 4 months ago

Attachment: pre-remove.png added

How items are selected before trying to remove them

by jadedctrl, 4 months ago

Attachment: post-remove.png added

How the playlist looks after trying to remove multiple items

comment:1 by jadedctrl, 4 months ago

Can't reproduce on 32bit. I think it has to do with the conversions between int32s and addr_ts, I'll try for a fix.

comment:2 by waddlesplash, 4 months ago

Resolution: fixed
Status: newclosed

Patch merged in hrev54820. Thanks for the fix!

comment:3 by waddlesplash, 4 months ago

Milestone: UnscheduledR1/beta3
Note: See TracTickets for help on using tickets.