Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1671 closed bug (fixed)

Asus EEEPC can't boot.

Reported by: kvdman Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc: ModeenF, eforgeot@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Hi,

I've got an Asus EEEPC (701) here, seems Haiku can't find the boot partition.

Attached is a screenshot with backtrace.

Attachments (6)

eeepc.jpg (101.5 KB) - added by kvdman 6 years ago.
IMG_0070.JPG (196.6 KB) - added by kvdman 6 years ago.
IMG_0071.JPG (145.3 KB) - added by kvdman 6 years ago.
IMG_0072.JPG (168.7 KB) - added by kvdman 6 years ago.
IMG_0073.JPG (249.1 KB) - added by kvdman 6 years ago.
haiku_eeepc_dscn2566.jpg (122.6 KB) - added by farvardin 6 years ago.
haiku booting from a SD card

Download all attachments as: .zip

Change History (25)

Changed 6 years ago by kvdman

comment:1 Changed 6 years ago by korli

I suppose there is no serial output : could you try to attach the output of lspci on linux ?

comment:2 Changed 6 years ago by marcusoverhagen

  • Owner changed from axeld to marcusoverhagen

comment:3 Changed 6 years ago by marcusoverhagen

  • Status changed from new to assigned

Please try to remove the generic_ide_pci driver from the image.
Does it boot after that?

Please also attach the lspci output as suggested by Korli.

comment:4 Changed 6 years ago by modeenf

  • Cc ModeenF added

comment:5 Changed 6 years ago by kvdman

I've removed generic_ide_pci but ran into the same problem...

btw, I did a search for generic_ide_pci and found two files, one was a symlink, and it was broken, the other was the binary. Or does it only link when it needs the driver?

Anyways, lcpci can be found here for the EEEPC:

http://www.fabianrodriguez.com/blog/archives/2007/10/26/ubuntu-710-gibbon-swings-on-the-asus-eee/

comment:6 Changed 6 years ago by axeld

How did you install Haiku on the EeePC?
If you've put it onto an SD card in the slot, it's likely that its accessed via USB - and that's something that Haiku does not support yet. You need to install Haiku on the internal disk to have a chance to boot it for now.

comment:7 Changed 6 years ago by kvdman

I made installed Windows XP (on the internal disk), then made a Partition after Windows. I used Vmware to access the physical disk, and formatted and mounted the disk in a BeOS virtual machine, then mounted a Haiku image and copied the files and made it bootable. Finally, I used bootpart to add the Haiku partition to the NT bootloader.

It would be much simpler if there was a 'makebootable' for Windows.

Anyways, the partition with Haiku does show the splashscreen and boot, but gets stuck.

Also, in case you're wondering I've tried BeOS and Zeta, and they both complain/get stuck when trying to load USB, even when I disable USB in the BIOS.

I also tried installing Haiku on a 16gb SDHC card, but that didn't work (as Axel described).


comment:8 Changed 6 years ago by marcusoverhagen

Can you please at least take another screenshot of the console debug output that gets printed before the panic, when booting with the generic_ide_pci driver is removed? it should be very different. If possible, please apply the paginate patch from ticket #1444 and make some photos of the complete boot process.

comment:9 Changed 6 years ago by kvdman

Since I can access the Haiku partition through a BeOS virtual machine in Windows, can you please tell me where I get the syslog, or how to enable it, then I won't need to take all the pictures - I'm not familiar with the process.

Changed 6 years ago by kvdman

Changed 6 years ago by kvdman

Changed 6 years ago by kvdman

Changed 6 years ago by kvdman

comment:10 Changed 6 years ago by kvdman

I've added these screenshots with generic_ide_pci removed, and the output was a lot different. Hope it's of use.

comment:11 Changed 6 years ago by kvdman

Hi Marcus,

I've made pictures of all the screens booting up the eeepc and leading up to the crash. They are in this archive:

http://www.haikuware.com/downloads/registered/eeepc.zip

If you can't make out some of them, let me know!

Karl

comment:12 Changed 6 years ago by kvdman

Some of those weren't very good, I took 2 pictures of each screen and kept the best one. Please use this archive instead:

http://www.haikuware.com/downloads/registered/eeepc2.zip

The boot screen order goes chronologically by file number.

comment:13 Changed 6 years ago by kvdman

Oh, and this was rev24521 with generic_ide removed.

comment:14 Changed 6 years ago by powelly

I just tried rev25750 on my eee and it booted perfectly.

To install Haiku on the eee I first booted Linux from a USB memory stick, then downloaded the rev25750 raw image and then used dd to write it directly to the internal flash HD. (sudo dd if=haiku.image of=/dev/sda). Rebooted the machine and Haiku booted.

Copying the image directly to the HD means you can only use a few hundred MB of the disk, not the full 4GB. Though that's my fault for the quick and easy install method. ;-)

There's no LAN, Wireless or Sound driver support for the eee hardware (In the default haiku image). There's also a strange issue with the video display. In 800x480 res. the right hand side of the screen (I'm guessing at the 640 pixel boundry) stay black even though the Deskbar is still there and working. Setting the screen to 640x480 works, but of course the display is stretched.

comment:15 Changed 6 years ago by modeenf

Apparently there are a way to boot Haiku from USB these days.
http://www.freelists.org/archives/openbeos/06-2008/msg00026.html

The installed image on the USB will be the same size as size in the haiku.img

comment:16 Changed 6 years ago by kvdman

Please close this:

http://www.haikuware.com/20080730230/latest/haiku-running-on-asus-eeepc

I can second powelly's findings.

comment:17 Changed 6 years ago by axeld

  • Resolution set to fixed
  • Status changed from assigned to closed

Seems to work for quite some time, it definitely boots fine on the Eee 900, too.

comment:18 Changed 6 years ago by farvardin

  • Cc eforgeot@… added
  • Platform changed from All to x86

I've copied the latest nightly build (19 Aug. 2008) to a SD card (using dd). It starts booting haiku, but at the end of the booting process, there is a kernel panic. Probably this is related to the USB support of haiku, but it would be nice to be able to boot haiku this way.

Changed 6 years ago by farvardin

haiku booting from a SD card

comment:19 Changed 6 years ago by mmlr

Please open a new bug report for your issue as it is not related to this bug and this bug has been closed already. Can you also provide a stack trace of the KDL using the "sc" command and include some details to the SD card used?

Note: See TracTickets for help on using tickets.