Opened 2 months ago

Last modified 8 weeks ago

#16718 new bug

Link opening page in new window doesn't works

Reported by: miqlas Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86-64

Description

An example: at https://github.com/haiku/haiku on the right sidebar there is a link: https://www.haiku-inc.org/donate/

  • Clicking it with LMB it opens a new tab but i get "Connection refused" error
  • Clicking it with MMB it loads in a new tab just fine.

WP's URL bar contains the same address, but even clicking into the URL bar and pressing enter fails too with the same error. Editing the URL also doesn't help.

Attachments (2)

screenshot94.png (38.2 KB ) - added by miqlas 2 months ago.
screenshot95.png (153.7 KB ) - added by miqlas 2 months ago.

Download all attachments as: .zip

Change History (10)

comment:1 by humdinger, 2 months ago

This works in Web+ (rebased Dec. 6th 2020).

comment:2 by miqlas, 2 months ago

This definetely happens here on both of my computer. What else could be the culprit for this?

by miqlas, 2 months ago

Attachment: screenshot94.png added

by miqlas, 2 months ago

Attachment: screenshot95.png added

comment:3 by miqlas, 2 months ago

Hmmm... No, it happens only on one computer, the other one works ok. Any idea how to find out the reason?

comment:4 by miqlas, 2 months ago

Of course both computer runs the same WP, same Haiku, even same arch. The problematic one connected trough lan, while the working one is on wlan, if that makes any difference.

comment:5 by pulkomandy, 2 months ago

Try deleting/moving away your webpositive settings?

Any difference in IPv4/v6 settings?

comment:6 by miqlas, 8 weeks ago

I think the hosts file generated by hblock is the culprit.

comment:7 by miqlas, 8 weeks ago

Haiku's hosts file content:

#
# Haiku's static hostname lookup table
#

127.0.0.1   localhost.localdomain localhost
::1         localhost.localdomain localhost

hblock's hosts file header:

# Generated with:  https://github.com/hectorm/hblock
# Blocked domains: 537654

# BEGIN HEADER
127.0.0.1       localhost Flatty
255.255.255.255 broadcasthost
::1             localhost Flatty
::1             ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters
ff02::3         ip6-allhosts
# END HEADER

comment:8 by miqlas, 8 weeks ago

Tested, the bug is somehow related to the hblock hosts file header. Replacing the header section solved the problem.

Note: See TracTickets for help on using tickets.