Opened 2 months ago

Closed 7 weeks ago

#16788 closed bug (fixed)

app_server crash when changing fonts in Vision

Reported by: roiredxsoto Owned by: axeld
Priority: normal Milestone: R1/beta3
Component: Servers/app_server Version: R1/beta2
Keywords: change font Cc:
Blocked By: Blocking:
Platform: All

Description

Good day,

~> uname -a
Haiku Corvus 1 hrev54945 Feb  5 2021 08:46:28 x86_64 x86_64 Haiku

Attempting to change the fonts in Vision produces a trip to KDL. Steps to reproduce:

  1. - Open Vision Preferences
  2. - Select the Fonts preferences
  3. - Attempt to change font in the Font dropdown menu
  4. - System crash

Inside KDL can use the debugger and save the report (attached file), though I couldn't go back to the desktop and had to force shutdown and turn on again.

Regards,
RR

Attachments (4)

app_server-911-debug-05-02-2021-19-28-40.report (243.8 KB ) - added by roiredxsoto 2 months ago.
App_server crash report produced when attempting to change fonts in Vision
syslog.old (512.0 KB ) - added by roiredxsoto 2 months ago.
Syslog prior to app_server crash
app_server-911-debug-11-02-2021-17-53-02.report (239.0 KB ) - added by roiredxsoto 2 months ago.
20210211 app_server crash report after selecting Anonymous Pro in FontBoy
app_server-566-debug-14-02-2021-08-24-14.report (55.0 KB ) - added by nephele 2 months ago.
Comprehensive debug report: Anonymous pro bold

Download all attachments as: .zip

Change History (20)

by roiredxsoto, 2 months ago

App_server crash report produced when attempting to change fonts in Vision

by roiredxsoto, 2 months ago

Attachment: syslog.old added

Syslog prior to app_server crash

comment:1 by nephele, 2 months ago

Hey, do you have any additional fonts installed above the normal set?

comment:2 by madmax, 2 months ago

And do you always get a crash? I've tried a few times and didn't. Does it need to have conversation windows open to happen, or it triggers even without a connection? What font do you have and which one do you set, or it doesn't matter? Does it crash on clean boot without having run anything else yet?

Not that any of that would be the culprit of the bug, but might help in tracking it.

comment:3 by roiredxsoto, 2 months ago

Good day,

@nephele, yes I have plenty of fonts installed besides the normal set.

@madmax, yes I get always the crash the moment I try to navigate through the font list. Vision's font list shows the font face, as opposite to the Appearance preferences. Changing font in the Appearance preferences works fine though. I'll retest again and post any changes.

I'll also review the font folder to check if something is wrong there too.

Regards,
RR

comment:4 by diver, 2 months ago

Most likely some font causes app_server to crash. Need to figure out which one.

comment:5 by nephele, 2 months ago

Could you provide the list of fonts you have? (assuming they are from haikudepot)

comment:6 by nephele, 2 months ago

It was mentioned on discuss that this issue may be the same one as anonymous pro crashing the app_server, i managed to reproduce this with the fontDemo application on a normal app_server (but not on a test app_server yet)

in reply to:  5 comment:7 by roiredxsoto, 2 months ago

Replying to nephele:

Could you provide the list of fonts you have? (assuming they are from haikudepot)

Good day @nephele,
The fonts are not from HaikuDepot, they are the fonts that I've been collecting for years to do graphic design. Actually none is from HaikuDepot I only have the Default Haiku fonts in /system, and all my fonts in /home. I'll check if one of them is the Anonymous font posted on the forums or if it is another one, if I can see the font name before the crash.

Regards,
RR

comment:8 by nephele, 2 months ago

You can try selecting the font in FontDemo instead, that might give you a better idea to narrow it down, another might be to simply devide and conquer, randomly move half the fonts out, see if it crashed, if it doesn't use the second set, if it does halve that, and repeat. :)

comment:9 by roiredxsoto, 2 months ago

Good day,

I was testing this, and proved that Anonymous Pro causes same crash inside FontBoy. Selecting that font causes the same app_server crash. Attached is the new app_server crash report.

Nonetheless, there are other fonts that also produce the same effect. I removed the Anonymous Pro font from the /fonts folder and it allows to scroll down a bit longer through the available fonts. I couldn't see the next one in the alphabetical list, the one that triggered the crash. It's weird.

@nephele, as you said, I'll have to keep checking wich ones cause the trouble and remove them. Anyway, I find it quite strange that selecting a font type triggers that kind of crash... :-?

Besides, it only seems to happen in places where fonts show their font faces. Appearance preferences doesn't trigger any crash, but then Appearance preferences doesn't show the font face when you select some font type.

Regards,
RR

Last edited 2 months ago by roiredxsoto (previous) (diff)

by roiredxsoto, 2 months ago

20210211 app_server crash report after selecting Anonymous Pro in FontBoy

comment:10 by nephele, 2 months ago

@nephele, as you said, I'll have to keep checking wich ones cause the trouble and remove them. Anyway, I find it quite strange that selecting a font type triggers that kind of crash... :-?

All font rendering goes through app_server, it seems we have an error that occurs with specific fonts, but not all of them. Knowing that anonymous pro crashed the app_server in that manner is probably enough to attempt a fix locally.

After that we can see if your issue is gone or if it's severall issues.

comment:11 by humdinger, 2 months ago

Related to this methusabug: #7995 ?

by nephele, 2 months ago

Comprehensive debug report: Anonymous pro bold

comment:12 by nephele, 2 months ago

I attached a debug report with comprehensive debug symbols that occurs when selecting anonymous pro bold in FontDemo.

comment:13 by waddlesplash, 2 months ago

This is clearly due to some kind of memory fault. Can you please run with the guarded heap?

comment:14 by nephele, 2 months ago

Hey, how would I do that? Haven't been able to find any documentation about the guarded heap.

comment:16 by pulkomandy, 7 weeks ago

Milestone: UnscheduledR1/beta3
Resolution: fixed
Status: newclosed

Patch submitted in hrev54966, thanks!

Note: See TracTickets for help on using tickets.