Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1681 closed bug (fixed)

Input server: no method's menu

Reported by: anthonylee Owned by: korli
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc: axeld
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

There are no menu in input method tray of DeskBar.

Change History (13)

comment:1 Changed 11 years ago by korli

As far I remember, the menu is working with the Canna IM. Does the problem appear only with BeCKJ ?

comment:2 Changed 11 years ago by anthonylee

Does the problem appear only with BeCKJ ?

No, same problem when only use Canna, in the menu of DeskBar, only show "<empty>".

I noticed this bug probably was connected with BUG of BMenu::Instantiate() when I test "MethodAddonTest" on Haiku.

BMenu::Instantiate() can't do a sub-menu instantiation.

BTW, BTextView's redraw action need to expand a pixel around the region.

comment:3 Changed 11 years ago by jackburton

The popup menu of Canna definitely worked in the past, so this is a regression. Will have to test which change caused it.

BTW It's not a good idea to put multiple bug reports in the same ticket. It's better to open a different ticket for the TextView problem.

comment:4 Changed 11 years ago by jackburton

Forgot this: The empty menu in canna/BeCKJ could be also caused by a problem in BView scripting. Last time it got broken it was because of that.

comment:5 Changed 11 years ago by korli

Cc: axeld added

Actually it's broken since hrev21959. The internal name of the deskbar window changed and is now w>Deskbar instead of Deskbar ... Axel, what was the reason for the change ?

comment:6 Changed 11 years ago by axeld

Axel, what was the reason for the change?

Well, it was broken and inconsistent before (SetTitle() would rename it, _InitData() did not). Why is renaming a thread/port a problem for another component? That doesn't sound healthy to me... can you point me to the problematic code so that I get a better understanding of the problem? Of course we could leave out the "w>" in the handler name easily if that's what we have to do :)

comment:7 in reply to:  6 Changed 11 years ago by korli

Replying to axeld:

Well, it was broken and inconsistent before (SetTitle() would rename it, _InitData() did not). Why is renaming a thread/port a problem for another component? That doesn't sound healthy to me... can you point me to the problematic code so that I get a better understanding of the problem? Of course we could leave out the "w>" in the handler name easily if that's what we have to do :)

Have a look in src/servers/input/AddOnManager.cpp method LoadReplicant(). The window specifier is "Deskbar". The handler name is the one used in this case.

comment:8 Changed 11 years ago by axeld

Resolution: fixed
Status: newclosed

The problem should be fixed with hrev23239. Can you confirm? The handler still has the "w>" prefix which is not the case on BeOS - I'll change that after we closed this bug.

comment:9 Changed 11 years ago by korli

Thanks Axel. It's fixed.

comment:10 Changed 11 years ago by axeld

Thanks for the update! I looked into the handler naming, but BeOS is not consistent here, so I think we should just keep what we have for now - until that proves to be problematic :-)

comment:11 Changed 11 years ago by axeld

Component: Servers/input_serverKits/Interface Kit

comment:12 Changed 11 years ago by anthonylee

I just try it, the menu shown, then I click the keyboard icon to active canna input method and select "About Canna..." from the popup menu, first time it popup a window and look fine, but second time it can't work likes DeskBar did not invoke a message to input server.

Then I try other menuitems in Canna's popup menu, the same problem occurred. Try BeCJK again, I can't change the interface language from the popup menu too.

comment:13 Changed 11 years ago by korli

Could you open a new bug for your last comment please ? Else, it could be forgotten :)

Note: See TracTickets for help on using tickets.