Opened 12 years ago

Closed 9 years ago

#1687 closed bug (fixed)

VLC Wont Close Stuck on w>Messages Thread

Reported by: cebif Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

VLC crashed when trying to close a streaming asx video from NASA TV. The steps to reproduce are: 1) Open an asx file that connects to a internet video stream. 2) After it starts playing click the VLC stop button. 3) Click the close button in the window tab. VLC does not close. The way I closed it was by killing the w>Messages thread from process controller. It was using most of the CPU cycles. The expected behaviour is that VLC should close its window and all associated threads. I was using VLC 0.86C and haiku.image.23198

Attachments (1)

gdb and backtrace (29.8 KB) - added by cebif 12 years ago.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by cebif

Attachment: gdb and backtrace added

comment:1 Changed 12 years ago by cebif

I have seen this bug only occuring when the internet connection is getting slow. If it is fast or normal and I go through the steps above, there is no problem closing VLC. I am not certain if this might be a bug in VLC itself not part of Haiku. A similar thing might be happening in Windows.

comment:2 Changed 12 years ago by stippi

Just a comment with regards to killing individual threads of a team - this is possible. It is not supposed to kill the team as a whole. It might cause all kinds of unexpected behavior in the application, if a thread is suddenly gone, but the system allows you to do this. You can also kill the team, and that should behave like you expected. However, I am not closing this bug as invalid, since I guess it is the original problem which caused you to need to kill VLC, for which you opened this bug. :-)

comment:3 Changed 12 years ago by cebif

The part of my previous comment "I am not certain if this might be a bug in VLC itself not part of Haiku. A similar thing might be happening in Windows." is not anything. There is hardly anything reproduceable in Windows as in Haiku. Also nothing like this is reproduceable in Beos R5.05 bone.

comment:4 Changed 11 years ago by cebif

Where I said "I have seen this bug only occuring when the internet connection is getting slow. If it is fast or normal and I go through the steps above, there is no problem closing VLC." in my first comment, does not apply anymore, at least in hrev23695. I had reason to say this though at the time when testing with hrev23198. It now crashes or wont close if the internet connection is fast or slow.

comment:5 Changed 9 years ago by mmadia

Does this still occur on R1/Alpha 2 or trunk?

comment:6 Changed 9 years ago by scottmc

Resolution: fixed
Status: newclosed

First reported and last checked 3yrs ago, lots of network changes since then. Closing this one as probably fixed. If it's still failing for you please provide links to videos that are having this issue.

Note: See TracTickets for help on using tickets.