Opened 12 years ago

Closed 10 years ago

#1696 closed bug (fixed)

Wrong display resolution on first boot with nvidia graphic cards

Reported by: ekdahl Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The correct (native) panel resolution is not selected at first boot with nvidia cards. Should collect the info from EDID data.

Change History (7)

comment:1 by axeld, 12 years ago

Owner: changed from axeld to rudolfc

The nVidia driver currently does not support EDID. It does also not support changing the actual resolution with a DVI connection, so even EDID might not help in this case (if the BIOS selects the wrong resolution on startup).

in reply to:  1 comment:2 by ekdahl, 12 years ago

Replying to axeld:

It does also not support changing the actual resolution with a DVI connection, so even EDID might not help in this case (if the BIOS selects the wrong resolution on startup).

I can change screen resolution using the Screen app and I have a geforce 6150 and DVI connection. Not sure what you mean.

comment:3 by axeld, 12 years ago

The nVidia driver can't change the display resolution - it will take over the resolution as detected by the BIOS. You obviously have no problem with this, but my 1680x1050 monitor is detected as 1280x1024, and there is no way I could set a higher resolution (everything is scaled based upon that base resolution).

comment:4 by apprentice, 11 years ago

I recently had a problem booting Haiku since it couldn't set my tft panel to it's native resolution so could the person that is doing the nvidia driver related work add the EDID support to this driver. Anyway I solved the problem by setting the resolution with vga and then switching the cable to DVI. The thread is in the support forum: http://www.haiku-os.org/community/forum/dvi_support

comment:5 by rudolfc, 10 years ago

implementing DDC/EDID is underway. I'm now dumping EDID data into the driver's logfile, and I am collecting data from testing numerous cards..

I'll keep you posted.

Rudolf.

comment:6 by rudolfc, 10 years ago

Update:

DDC/EDID is working these days, but will be a bit more extended / improved. Therefore leaving this ticket open for now.

BTW: the black-screen in non-native DVI mode was caused by the line: force_ws true in nvidia.settings earlier. That is fixed now since the default is now off and EDID detects WS screens automatically. Apart from a few cards on which EDID still doesn't work that is: even there the screen doesn't turn off because only 4:3 modes are offered.

Bye!

Rudolf.

comment:7 by rudolfc, 10 years ago

Resolution: fixed
Status: newclosed

EDID implementation is ready as of this week.

Closing ticket.

Bye!

Rudolf.

Note: See TracTickets for help on using tickets.