Opened 13 years ago

Closed 12 years ago

#170 closed bug (fixed)

About Haiku doesn't work in Deskbar

Reported by: j_freeman@… Owned by: bonefish
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc: diver, apotheosian@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Selecting "About Haiku" in Deskbar's appears to do nothing.

Change History (19)

comment:1 Changed 13 years ago by diver

I confirm this. Tested with rev16399.

comment:2 Changed 13 years ago by jackburton

Component: ApplicationsKits

comment:3 Changed 13 years ago by jackburton

Deskbar calls run_be_about in InterfaceDefs.cpp, which uses BRoster::Launch(const char *signature) to run AboutHaiku. The error returned is B_APPLICATION_NOT_FOUND. listattr /boot/beos/apps/AboutHaiku shows:

BEOS:TYPE BEOS:M:STD:ICON BEOS:APP_FLAGS BEOS:APP_VERSION BEOS:L_STD_ICON

BEOS:APP_SIG is missing, and it's probably the cause of this bug. Switching component...

comment:4 Changed 13 years ago by jackburton

Owner: changed from sikosis to bonefish

comment:5 Changed 13 years ago by korli

Seems to only happen on Linux build.

comment:6 Changed 13 years ago by korli

Cc: diver added

comment:7 Changed 13 years ago by korli

* Bug 324 has been marked as a duplicate of this bug. *

comment:8 Changed 13 years ago by mmlr

* Bug 538 has been marked as a duplicate of this bug. *

comment:9 Changed 13 years ago by mmlr

Cc: apotheosian@… added

comment:10 Changed 13 years ago by jackburton

* Bug 457 has been marked as a duplicate of this bug. *

comment:11 Changed 13 years ago by bonefish

Fixed in revision 17354.

comment:12 Changed 13 years ago by bonefish

Resolution: fixed

comment:13 Changed 13 years ago by bonefish

Status: newclosed

comment:14 Changed 13 years ago by korli

tested ok with linux build

comment:15 Changed 12 years ago by jfreeman

Platform: All

This problem seems to be back as of revisions 19180 (BeOS-built) and 19193 (CentOS-built).

comment:16 Changed 12 years ago by bga

Resolution: fixed
Status: closedreopened

I can confirm the problem is back (About does not start when "About Haiku" is selected in Deskbar). Reopening the bug.

comment:17 Changed 12 years ago by bga

BTW, I did take a look at the code and it seems that when Deskbar is compiled for Haiku, it really does nothing when "About Haiku" is selected. Maybe a bug introduced with a previous commit? I will check it.

comment:18 in reply to:  17 Changed 12 years ago by jackburton

Replying to bga:

BTW, I did take a look at the code and it seems that when Deskbar is compiled for Haiku, it really does nothing when "About Haiku" is selected. Maybe a bug introduced with a previous commit? I will check it.

I just tried here with the latest image dowloaded from haikuhost: the first time "About Haiku" showed up, then not anymore.

comment:19 Changed 12 years ago by bga

Resolution: fixed
Status: reopenedclosed

Confirmed as a bug introduced by axeld when he changed the application signatures. He just fixed it on hrev19218.

Sometimes I wonder why we still keep him as a developer!

;)

Note: See TracTickets for help on using tickets.