Opened 2 months ago

Closed 2 weeks ago

Last modified 2 weeks ago

#17072 closed bug (fixed)

Unable to boot ISO

Reported by: Coldfirex Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: System Version: R1/beta3
Keywords: Cc:
Blocked By: Blocking:
Platform: x86-64

Description (last modified by Coldfirex)

Howdy, I am finally getting around to testing Haiku on real hardware (AMD 3300x, 16GB, nvidia 1650 super, etc). I am using the B3-TC2 ISO and a couple times it has booted to the installer and live desktop correctly. Most of the time, however, it fails at the Haiku icons. When this happens:

*None of the icons light up.

*Safe mode does not help much (1/10 times I got it to boot)

*Video fallback and disabling USB and nvidia driver didnt do anything

*My usb keyboard shuts off when it fails to boot

*It appears to be a hard lock and I have to power off the system to retry

*No change with APIC, SMP, ACPI, SMEP, etc disabled

*The onscreen debugging is always the same, but I dont see a printed error https://imgur.com/a/gjelywO and log output https://pastebin.com/7NqB3DNc.

Successful boot log https://pastebin.com/gcFyy9zK

Attachments (1)

syslog-working.txt (254.2 KB ) - added by Coldfirex 2 weeks ago.

Download all attachments as: .zip

Change History (10)

comment:1 by Coldfirex, 2 months ago

Description: modified (diff)

comment:2 by Coldfirex, 2 months ago

Description: modified (diff)

comment:3 by Coldfirex, 2 months ago

Description: modified (diff)

comment:4 by kallisti5, 2 months ago

"None of the icons light up."

Hm. I used to see something like this on my system. Are you booting our media via EFI or BIOS? (generally, bios boot menus will show "USB STICK XXX, EFI: USB STICK XXX". You want the one prefixed by EFI.

My Ryzen desktop won't boot via the older mbr method and shows a similar fault, but works fine via EFI.

comment:5 by Coldfirex, 2 months ago

So all the tests were with EFI above. I tried the old style and actually had worse luck. Sometimes the bootloader options would never appear, sometimes I would only get a blinking cursor before the iso boot loader, sometimes the same result of no icons lit up, and sometimes even just nothing. Keyboard was always "locked". I reflashed by USB key with a fresh TC ISO to be safe as well.

Are there any alternatives to getting boot logs if no serial output at this point?

comment:6 by Coldfirex, 2 weeks ago

After the recent USB changes I was able to boot off of a new anyboot ISO (hrev55376). Feel free to close.

comment:7 by tqh, 2 weeks ago

Resolution: fixed
Status: newclosed

comment:8 by waddlesplash, 2 weeks ago

KERN: usb error xhci 0: ConfigureEndpoint() failed invalid max_burst_payload
KERN: usb error xhci 0: unable to configure endpoint: Invalid Argument

by Coldfirex, 2 weeks ago

Attachment: syslog-working.txt added

comment:9 by waddlesplash, 2 weeks ago

Well, that error is still in there, and I don't see any considerable differences in your syslog. I'm not really convinced this is really XHCI related; it seems your failed-boot cut off long before XHCI would actually have initialized or done anything. Possibly some other change in recent weeks fixed this, but not the USB ones.

Note: See TracTickets for help on using tickets.