#17165 closed bug (fixed)

Possible replacement of NTFS driver

Reported by: pulkomandy Owned by: waddlesplash
Priority: normal Milestone: R1/beta4
Component: File Systems/NTFS Version: R1/beta3
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

Our current NTFS driver is a kernel side port of NTFS-3G (Linux driver running in userland). It has some problems.

We have discussed replacing it with other implenentations. Just creating this ticket to keep track of the ideas and discussions in a single place.

One alternative is using Apple's NTFS driver: https://opensource.apple.com/source/ntfs/ (published under APPLE PUBLIC SOURCE LICENSE)

More recently, a new driver has been published by Paragon software under GPLv2 and with plans to introduce it in Linux: https://www.paragon-software.com/us/home/ntfs3-driver-faq/

Change History (4)

comment:1 by waddlesplash, 16 months ago

The problems, as far as I've been able to determine, are largely caused by our glue code being not so great.

NTFS-3G has some glue code to a lower-level version of FUSE that looks much more like a kernel-level FS interface, and it indeed does things kind of differently to the way we do them. I have been meaning to look at rewriting our glue code based instead around that code from NTFS-3G, as well as adding file cache support, because that probably will fix a lot / most of our problems.

comment:2 by waddlesplash, 14 months ago

Owner: changed from 3dEyes to waddlesplash
Status: newin-progress

comment:3 by waddlesplash, 14 months ago

New driver glue, first part: https://review.haiku-os.org/c/haiku/+/4679

comment:4 by waddlesplash, 13 months ago

Milestone: UnscheduledR1/beta4
Resolution: fixed
Status: in-progressclosed

NTFS driver glue replaced in hrev55628.

Note: See TracTickets for help on using tickets.