Opened 12 years ago

Closed 7 years ago

Last modified 7 years ago

#1717 closed enhancement (fixed)

BFilePanel, initially filtered files (BRefFilter) aren't watched for changes

Reported by: anevilyak Owned by: aldeck
Priority: normal Milestone: R1
Component: Applications/Tracker Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If I have Wonderbrush open, with the open new file BFilePanel active and looking at /boot/home, and I hit printscreen to dump a screenshot, screen*.png does not show up in the filepanel without cancelling and reopening it.

Change History (12)

comment:1 Changed 12 years ago by stippi

Component: System/Kernel- Applications/Tracker

I just checked on ZETA (with OpenTracker installed) and there it behaves the same (ie the file does not show up). So this bug is not Haiku specific, but likely a Tracker bug. Switching components.

comment:2 Changed 12 years ago by axeld

I would guess it's likely a problem of the MIME type filter; when the file is created, it does not have qualify as an image yet, and might be disregarded because of that.

comment:3 Changed 12 years ago by stippi

That's a very good explanation. One more reason to have a notification when a file is "finished"...

comment:4 Changed 12 years ago by anevilyak

That was one of my thoughts as well, though....doesn't a mime type / attribute change send the monitor a B_STAT_CHANGED? Or do those not get passed on to the ref filter?

comment:5 Changed 10 years ago by aldeck

Must have been fixed in the mean time. Tested here with StyledEdit's 'Open File' panel, hrev29443. Can someone else confirm so we can close the ticket safely?

comment:6 Changed 10 years ago by luroh

Works in StyleEdit indeed, but not in Wonderbrush. Tested with 29446.

comment:7 Changed 10 years ago by anevilyak

Resolution: fixed
Status: newclosed

Fixed in hrev31307.

comment:8 Changed 10 years ago by aldeck

Resolution: fixed
Status: closedreopened
Type: bugenhancement

Reopening, hrev31307 would cause #4130. See hrev33769

comment:9 Changed 10 years ago by axeld

Owner: changed from axeld to aldeck
Status: reopenednew
Version: R1/pre-alpha1

comment:10 Changed 10 years ago by aldeck

Summary: Node monitoring not working correctly in BFilePanelBFilePanel, initially filtered files (BRefFilter) aren't watched for changes

comment:11 Changed 7 years ago by stpere

Resolution: fixed
Status: newclosed

Should be fixed in hrev44493, please test.

comment:12 Changed 7 years ago by humdinger

I confirm. The ticket's issue isn't reproducible any more. Thanks for all your fixes lately!

Note: See TracTickets for help on using tickets.