Opened 12 years ago

Closed 12 years ago

#1721 closed bug (duplicate)

MouseDown don't reach Window for Mozilla menus/popups

Reported by: fyysik Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

follow-up for ticket 1714 I hope I use build with both Axel's and Stephan's patches commited. While in main window of Mozilla mouse works properly, this is something very strange happening with menus (popups in Mozilla terms).

While MouseMove and MouseUp events reach BWindow successfully, MouseDown does not appear in BWindow's DispatchMessages either in BView's MouseDown.

Mozilla menus don't use any BMenu and relatives - it is separate BWindow with BView. BWindow has two specific flags set (not used in other Mozwidgets) - B_AVOID_FOCUS | B_NO_WORKSPACE_ACTIVATION.

Any idea for more detailed debugging?

Change History (2)

comment:1 Changed 12 years ago by fyysik

TRACK worked with flaws, so it is duplicate of 1720

comment:2 Changed 12 years ago by nielx

Resolution: duplicate
Status: newclosed

Duplicate of #1720

Note: See TracTickets for help on using tickets.