#17255 closed bug (invalid)

BePDF now broken in hrev55402

Reported by: shaka Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: BePDF Cc:
Blocked By: Blocking:
Platform: x86-64

Description (last modified by shaka)

BePDF now broken in hrev55402 (x86_64) error message about missing symbol _ZTI4BRow.

Reverting to previous system state hrev55399 fixes problem.

Attachments (3)

Bitmap Clip.bmp (17.6 KB ) - added by shaka 13 months ago.
screenshot1.png (60.3 KB ) - added by shaka 13 months ago.
Clip.bmp (10.1 KB ) - added by shaka 13 months ago.

Download all attachments as: .zip

Change History (11)

by shaka, 13 months ago

Attachment: Bitmap Clip.bmp added

by shaka, 13 months ago

Attachment: screenshot1.png added

comment:1 by shaka, 13 months ago

Description: modified (diff)

comment:2 by shaka, 13 months ago

Description: modified (diff)

comment:3 by X512, 13 months ago

Probably caused by hrev55402 that fixed undesired symbol export. BePDF need to be rebuilt.

in reply to:  3 comment:4 by korli, 13 months ago

Replying to X512:

BePDF need to be rebuilt.

Difficult, given that the buildbot stay on beta3. The change would need to happen at Haikuports or BePDF somehow.

Maybe the link order is important here (columnlistview comes at the moment after libbe) https://github.com/HaikuArchives/BePDF/blob/master/bepdf/Makefile#L96

Last edited 13 months ago by korli (previous) (diff)

comment:5 by waddlesplash, 13 months ago

columnlistview is really in libtracker. Yes, changing the link order should help, I believe.

by shaka, 13 months ago

Attachment: Clip.bmp added

comment:6 by shaka, 13 months ago

NOTE: DocumentViewer (another PDF reader) is not working now either, so the problem may be bigger than just BePDF's source code.

comment:7 by waddlesplash, 13 months ago

It's probably the same issue.

comment:8 by waddlesplash, 13 months ago

Resolution: invalid
Status: newclosed

Moving this issue over to HaikuPorts: https://github.com/haikuports/haikuports/issues/6179

BePDF fixed and should be rebuilt soon.

Note: See TracTickets for help on using tickets.