Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#17594 closed bug (duplicate)

General system unresponsiveness, Huawei Matebook D15 Intel

Reported by: kquote03 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers Version: R1/Development
Keywords: Cc:
Blocked By: #17595 Blocking:
Platform: x86-64

Description (last modified by kquote03)

First of all, I would like to thank everyone, because it's honestly just very impressive that haiku is able to even run on such a machine! I even managed to install it on an NVMe SSD and it boot just fine! (thank you Mr. Waddlesplash)

Tho while booted, there some issues, the touchpad doesn't work (it's probably a separate issue, it uses i2c bus) so I have to use a USB mouse, but the mouse is very laggy, this might be an XHCI bug, but I'm not sure. This laptop only has an XHCI controller, the USB 2.0 ports go through it, sort of like a built-in hub. I even tried to blacklist XHCI just in case, and yea, the ports no longer function.

Audio.. works! but is very choppy, I do not know if this is related tho.

Opening context menus takes somewhere from instantly to a whole minute. It is very random.

Pulse reports my CPU as having 45 GHz, I don't know if this is related too.

System specs: Huawei Matebook D15 2021 (BOD-WXX9 M1040) CPU: 11th Gen Intel i5-1135G7 (8) @ 4.200GHz GPU: Intel TigerLake-LP GT2 [Iris Xe Graphics] hrev: 55848

I've attached the assumed relevant files as instructed on the dev wiki. Thanks in advance!

Attachments (11)

listdev.txt (2.1 KB ) - added by kquote03 7 months ago.
listusbdashv.txt (23.9 KB ) - added by kquote03 7 months ago.
listimagegrepdrivers.txt (1.5 KB ) - added by kquote03 7 months ago.
syslog (326.9 KB ) - added by kquote03 7 months ago.
screenshot1.png (108.5 KB ) - added by kquote03 7 months ago.
pulse reporting 45GHz
Listdev Huawei Mach-W19 (2.8 KB ) - added by atomozero 7 months ago.
asus-listdev.txt (3.2 KB ) - added by kquote03 7 months ago.
asus-syslog.txt (205.8 KB ) - added by kquote03 7 months ago.
huawei-sysinfo.txt (6.4 KB ) - added by kquote03 7 months ago.
Anyways, here's sysinfo from the huawei laptop
screenshot Huawei Mach-W19.png (456.5 KB ) - added by atomozero 7 months ago.
asus-sysinfo.txt (9.3 KB ) - added by kquote03 7 months ago.
sysinfo from the asus laptop

Download all attachments as: .zip

Change History (21)

by kquote03, 7 months ago

Attachment: listdev.txt added

by kquote03, 7 months ago

Attachment: listusbdashv.txt added

by kquote03, 7 months ago

Attachment: listimagegrepdrivers.txt added

by kquote03, 7 months ago

Attachment: syslog added

by kquote03, 7 months ago

Attachment: screenshot1.png added

pulse reporting 45GHz

comment:1 by kquote03, 7 months ago

Description: modified (diff)

touchpad uses i2c

comment:2 by waddlesplash, 7 months ago

It is probably related, yes.

Not sure why we are getting such a strange reading, though. The bootloader log may have more information here about timer calibration...

in reply to:  2 comment:3 by kquote03, 7 months ago

Replying to waddlesplash:

It is probably related, yes.

Not sure why we are getting such a strange reading, though. The bootloader log may have more information here about timer calibration...

Sorry for the delay, I slept, anyways https://imgur.com/a/3vpeKfi

comment:4 by atomozero, 7 months ago

I find myself with a similar solution, it works practically everything except the trackpad

~> listusb 05dc:a761 /dev/bus/usb/0/1/0 "Lexar Media, Inc." "JD FireFly" ver. 1100 045e:0737 /dev/bus/usb/0/1/1 "Microsoft Corp." "Compact Optical Mouse 500" ver. 0104 058f:9254 /dev/bus/usb/0/1/hub "Alcor Micro Corp." "Hub" ver. 0312 8087:0a2b /dev/bus/usb/0/4 "Intel Corp." "Bluetooth wireless interface" ver. 0010 05c8:03c0 /dev/bus/usb/0/6 "Cheng Uei Precision Industry Co., Ltd (Foxlink)" "HD Camera" ver. 0012 0000:0000 /dev/bus/usb/0/hub "HAIKU Inc." "XHCI RootHub" ver. 0300 ~>

by atomozero, 7 months ago

Attachment: Listdev Huawei Mach-W19 added

in reply to:  4 comment:5 by kquote03, 7 months ago

Replying to atomozero:

Your screenshot seems to be corrupted

comment:6 by kquote03, 7 months ago

I've tried haiku on a friend's laptop as well, I encountered the same exact issues (pulse ghz, usb, unresponsiveness etc) and audio didn't work, but I didn't try any fix. it's got the same CPU but is from a different manufacturer, ASUS. It's an ASUS TUF FX506H. I've attached a new syslog and listdev prefixed with ASUS.

by kquote03, 7 months ago

Attachment: asus-listdev.txt added

by kquote03, 7 months ago

Attachment: asus-syslog.txt added

comment:7 by korli, 7 months ago

What's the output of sysinfo?

in reply to:  7 comment:8 by kquote03, 7 months ago

Replying to korli:

What's the output of sysinfo?

For which laptop? I'll sadly have to do that tomorrow for the Asus, as it is not my laptop

by kquote03, 7 months ago

Attachment: huawei-sysinfo.txt added

Anyways, here's sysinfo from the huawei laptop

by atomozero, 7 months ago

by kquote03, 7 months ago

Attachment: asus-sysinfo.txt added

sysinfo from the asus laptop

comment:9 by kallisti5, 7 months ago

Blocked By: 17595 added
Resolution: duplicate
Status: newclosed

This one is a duplicate of #17595. (technically 17595 is a duplicate of this one, however the issue is more accurately described as an issue with "11th Gen Intel hardware", so I'm favoring #17595)

These logs are still valuable however. Thanks!

in reply to:  9 comment:10 by kquote03, 7 months ago

Replying to kallisti5:

This one is a duplicate of #17595. (technically 17595 is a duplicate of this one, however the issue is more accurately described as an issue with "11th Gen Intel hardware", so I'm favoring #17595)

These logs are still valuable however. Thanks!

Thanks for letting me know!!

Note: See TracTickets for help on using tickets.