Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#176 closed bug (fixed)

jam doesn't compile

Reported by: marcusoverhagen Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

jam doesn't compile, and the output is strange:

$ jam ...found 171 target(s)... ...updating 40 target(s)... Cc bin.beosx86/builtins.o Cc bin.beosx86/command.o Cc bin.beosx86/compile.o Cc bin.beosx86/execunix.o /Develop/buildtools/jam/execunix.c: In function `execcmd': /Develop/buildtools/jam/execunix.c:228: warning: passing arg 2 of `execvp' from incompatible pointer type Cc bin.beosx86/fileunix.o Cc bin.beosx86/pathunix.o GenFile1 jamgram.y jamgramtab.h Yacc1 jamgram.c jamgram.h YaccMv jamgram.c jamgram.h Cc bin.beosx86/jamgram.o Cc bin.beosx86/jcache.o Cc bin.beosx86/hcache.o /Develop/buildtools/jam/hcache.c: In function `cache_name': /Develop/buildtools/jam/hcache.c:88: warning: assignment discards qualifiers from pointer target type /Develop/buildtools/jam/hcache.c: In function `read_netstring': /Develop/buildtools/jam/hcache.c:153: warning: return discards qualifiers from pointer target type /Develop/buildtools/jam/hcache.c: In function `hcache': /Develop/buildtools/jam/hcache.c:361: warning: assignment discards qualifiers from pointer target type /Develop/buildtools/jam/hcache.c:410: warning: assignment discards qualifiers from pointer target type Cc bin.beosx86/beos_stat_cache.o Cc bin.beosx86/expand.o Cc bin.beosx86/glob.o Cc bin.beosx86/hash.o Cc bin.beosx86/headers.o Cc bin.beosx86/lists.o Cc bin.beosx86/make.o Cc bin.beosx86/make1.o Cc bin.beosx86/newstr.o Cc bin.beosx86/option.o Cc bin.beosx86/parse.o Cc bin.beosx86/regexp.o Cc bin.beosx86/rules.o Cc bin.beosx86/scan.o Cc bin.beosx86/search.o Cc bin.beosx86/timestamp.o Cc bin.beosx86/variable.o Archive bin.beosx86/libjam.a /boot/develop/tools/gnupro/bin/ar: creating bin.beosx86/libjam.a Ranlib bin.beosx86/libjam.a Cc bin.beosx86/mkjambase.o Link bin.beosx86/mkjambase Chmod1 bin.beosx86/mkjambase Cc bin.beosx86/jam.o GenFile1 jambase.c Cc bin.beosx86/jambase.o Link bin.beosx86/jam Chmod1 bin.beosx86/jam C++ bin.beosx86/StatCacheServer.o CompileResources bin.beosx86/StatCacheServer.rsrc /bin/sh: -o: command not found

RC= for arch in x86 ppc do for plat in hrev5 bone dano haiku do for version in release debug_1 debug_2 do PATH=../../../generated/objects/${plat}/${arch}/${version}/tools/rc/rc if [ -f $PATH ] then RC=$PATH break 3 fi done done done if [ -f $RC ]; then $RC -o "bin.beosx86/StatCacheServer.rsrc" "StatCacheServer.rdef" else echo "Error: Couldn't find rc, the resources compiler. It should " echo "Error: be located in objects/<arch>.<version>.<plat>/tools/rc/ and can be made" echo "Error: by invoking \`jam rc'. You can also build the" echo "Error: StatCacheServer without resources by running" echo "Error: NO_STAT_CACHE_SERVER_RESOURCES=1 jam" exit 1; fi

...failed CompileResources bin.beosx86/StatCacheServer.rsrc ... ...skipped StatCacheServer for lack of StatCacheServer.rsrc... ...failed updating 1 target(s)... ...skipped 1 target(s)... ...updated 38 target(s)... $

Change History (8)

comment:1 Changed 13 years ago by bonefish

Status: newassigned

comment:2 Changed 13 years ago by bonefish

The rc finding algorithm broke when I moved jam to the buildtools module. Not sure why the "if [ -f $RC ]" test doesn't catch this case. I can't access the repository at the moment, but I would remove this algorithm completely, anyway. You can define the NO_STAT_CACHE_SERVER_RESOURCES variable for the time being, if you need to recompile the StatCacheServer. Otherwise just compile jam itself ("jam jam").

comment:3 Changed 13 years ago by korli

Did you try if [ -f "$PATH" ] ?

comment:4 Changed 13 years ago by bonefish

* Bug 236 has been marked as a duplicate of this bug. *

comment:5 Changed 13 years ago by bonefish

Cc: axeld@… added

comment:6 Changed 13 years ago by bonefish

Resolution: fixed

comment:7 Changed 13 years ago by bonefish

Status: assignedclosed

comment:8 Changed 13 years ago by bonefish

Fixed in revision 16532. rc is no longer searched at all. It has to be specified via the RC environment variable, if resources shall be added.

Note: See TracTickets for help on using tickets.