Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#17631 closed bug (fixed)

"Source Activity" on the website doesn't update

Reported by: jmairboeck Owned by: kallisti5
Priority: critical Milestone: Unscheduled
Component: Sys-Admin Version:
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

The "Source Activity" tab on the website shows the most recent commit from 2 days ago. Previously it updated quite fast.

Is this because of the migration to k8s?

Change History (5)

comment:1 by waddlesplash, 9 months ago

Component: Website/www.haiku-os.orgSys-Admin
Owner: changed from waddlesplash to kallisti5
Status: newassigned

The problem is really that the GitHub mirror has not gotten any of the new commits. Indeed it's probably due to the migration.

comment:2 by waddlesplash, 9 months ago

Priority: normalcritical

comment:3 by kallisti5, 9 months ago

ah yeah.. there's a script running on limerick. I'll look into it after fixing the email issue

comment:4 by waddlesplash, 9 months ago

Resolution: fixed
Status: assignedclosed

Works again.

comment:5 by kallisti5, 9 months ago

yup.. created a container called gitsync which will sync a local git repo to github (or any git host) via a kubernetes CronJob. We could in theory also sync to bitbucket/gitlab/etc now pretty easily as well.

Note: See TracTickets for help on using tickets.