Opened 11 months ago

Last modified 11 months ago

#17660 new bug

VEGA 56 black screen

Reported by: andreas_dr Owned by: kallisti5
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

Hi,

i think its obvious that VEGA56 modesetting in accelerant/via kernel driver, both named "radeon_hd" is not working.

I try to gather some information, maybe to help, to fix those issues.

Symthoms are that screen gets black and nothing can be done anymore, although changing Num lock and Caps lock is working.

Please see attached my VEGA56 BIOS and radeon_hd traces.

Attachments (2)

220317-Haiku-VEGA56-radeon_hd_kernel_traces.txt.txt (14.8 KB ) - added by andreas_dr 11 months ago.
radeon_hd_bios_1002_687f_0.bin (128.0 KB ) - added by andreas_dr 11 months ago.

Download all attachments as: .zip

Change History (8)

by andreas_dr, 11 months ago

comment:1 by andreas_dr, 11 months ago

Feel free to ask anything if you have questions please.

comment:2 by nephele, 11 months ago

Component: - GeneralDrivers/Graphics/radeon_hd
Owner: changed from nobody to kallisti5
Summary: VEGA 56VEGA 56 black screen

What revision is this?

comment:3 by andreas_dr, 11 months ago

Its a custom build to extract the BIOS(it was deleted after next boot without accelerant) and traces. I should be able to give you the commit hash if thats sufficient. But I build yesterday freshly from sources. So 22-03-16.

comment:4 by korli, 11 months ago

Version: R1/beta3R1/Development

Duplicate #17516 ?

comment:5 by andreas_dr, 11 months ago

Yes but in my ticket the trace is complete from RADEON_HD and you see that BIOS does not get parsed correctly, which leads to all other problems. Also I have attached the BIOS so that the dev can adapt parser to it, at least this was one idea from me.

comment:6 by andreas_dr, 11 months ago

But yes, seems to be a duplicate.

Note: See TracTickets for help on using tickets.