Opened 11 years ago

Last modified 9 months ago

#1768 reopened bug

Binutils 2.17 objdump Broken

Reported by: bonefish Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc: zooey
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Binutils 2.17 objdump (070218 gcc package from BeBits) crashes when disassembling (gcc 2.95.3 generated) objects with debug info (objdump -D --demangle ...). Can be reproduced under both Haiku and BeOS.

I tracked down one problem to a dereferenced NULL pointer in opcodes/i386-dis.c:print_insn() (first putop() call). Apparently the bug has already been fixed in CVS version 1.132 (2007/08/02 00:40:02) of the file.

I get a different stack trace for another test file (libperl.so compiled with "-g") though, so it seems not to be the only problem.

Update to newer binutils recommended.

Change History (6)

comment:1 Changed 11 years ago by bonefish

I gave the binutils 2.18 a try, but merging the eh-frame stuff scared the shit out of me. Maybe it's possible to update only opcodes...

comment:2 Changed 4 years ago by waddlesplash

Resolution: fixed
Status: newclosed

We're on 2.24 ATM. This has long since been fixed.

comment:3 Changed 4 years ago by pulkomandy

We are not on 2.24 for gcc2...

comment:4 Changed 4 years ago by waddlesplash

Resolution: fixed
Status: closedreopened
Version: R1/pre-alpha1R1/Development

Oh, I see. My bad.

comment:5 Changed 11 months ago by cocobean

Last edited 11 months ago by cocobean (previous) (diff)

comment:6 Changed 9 months ago by cocobean

Reviewed on hrev 51986 x86 - (gcc 2.95.3_2017-07-20, objdump 2013-04-21, binutils 2.17_2016_07_24-4).

NOTE: Check with waddlesplash or korli on suggested binutils update to use.

Last edited 9 months ago by cocobean (previous) (diff)
Note: See TracTickets for help on using tickets.