Opened 11 years ago

Last modified 7 years ago

#1775 reopened bug

Tracker/BShelf crash on clicking replicant dragger menu

Reported by: elvencode Owned by: aldeck
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by aldeck)

Tested on build 23925

when clicking on the replicant grip 2/3 times moving a little the mouse the menu (or probably the start of rendering a selection box in the desktop) trigger a crash of the Tracker. It doesn't show up always but quite frequently.

edit: since hrev29949, it can only happen with a custom dragger popup menu. (cf. BeBook)

Attachments (2)

bt.png (23.0 KB) - added by elvencode 11 years ago.
This is the debugger content
serial-excerpt.txt (1013 bytes) - added by luroh 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by jackburton

Can you provide a stack trace ? ("bt" inside the debugger window).

Changed 11 years ago by elvencode

Attachment: bt.png added

This is the debugger content

comment:2 Changed 10 years ago by aldeck

I remember seeing that one quite frequently a few months ago, can't reproduce here, hrev29443 (vmware and real 2 cpus).

To elvencode and others: Can you check again?

comment:3 Changed 10 years ago by luroh

Still present in 29448. Tested in Vmware Player 2.5.0 (Ubuntu 8.10, 32-bit), using the replicant handle of DeskCalc.
Excerpt from serial output attached.

Changed 10 years ago by luroh

Attachment: serial-excerpt.txt added

comment:4 Changed 10 years ago by luroh

aldeck: you fixed something possibly similar some months ago, in hrev28089. Just thought I'd mention.

comment:5 Changed 10 years ago by aldeck

Owner: changed from stippi to aldeck
Status: newassigned

luroh: Ok, i can reproduce, thanks for testing. It happens when you drag the BDragger while the popup menu is showing. There's a locking issue when BDragger tries to archive its popup menu (for the replicant drag message). Will look into it.

comment:6 Changed 10 years ago by aldeck

Resolution: fixed
Status: assignedclosed

fixed in hrev29727

comment:7 Changed 10 years ago by aldeck

Resolution: fixed
Status: closedreopened

reopening, there's sometimes a problem when unlocking the popup menu's window, although, since hrev29949, it can only happen with customized dragger popups.

comment:8 Changed 9 years ago by aldeck

Description: modified (diff)
Summary: Tracker crash on clicking replicant menuTracker/BShelf crash on clicking replicant dragger menu

made the summary/description a bit more exact

comment:9 Changed 7 years ago by diver

Component: User InterfaceKits/Interface Kit
Note: See TracTickets for help on using tickets.