Opened 14 years ago

Closed 12 years ago

Last modified 12 years ago

#178 closed bug (fixed)

input_server should be restarted automatically

Reported by: marcusoverhagen Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version:
Keywords: Cc: diver, jonas.kirilla
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

After beein quit/killed/shutdown (don't know about crashed), input_server should be restarted automatically by registar

Change History (8)

comment:1 by bonefish, 14 years ago

Since the input server is started by the app server in the first place, I suppose, it's reasonable that the app server restarts the input server.

comment:2 by bonefish, 14 years ago

Owner: changed from bonefish to axeld

comment:3 by korli, 14 years ago

input_server isn't started by the app_server yet, only the bootscript. It could be started by app_server or registrar as input_server now registers itself to the app_server.

comment:4 by diver, 14 years ago

Cc: diver added

comment:5 by axeld, 13 years ago

Component: GeneralUser Interface/app_server
Description: modified (diff)
Platform: All

comment:6 by leavengood, 12 years ago

Resolution: fixed
Status: newclosed

I fixed this back in December in hrev19615.

comment:7 by jonas.kirilla, 12 years ago

It doesn't appear to be working as intended. When I quit or kill the input_server, the system hangs, or just the app_server maybe. Pressing F12 reboots the system instantly, having said:

"PANIC: page fault, but interrupts were disabled. Touching address 0x944c1800 from eip 0x8007b997

Welcome to Kernel Debugging Land..."

comment:8 by jonas.kirilla, 12 years ago

Cc: jonas.kirilla added
Note: See TracTickets for help on using tickets.