Opened 12 years ago

Closed 11 years ago

#1781 closed bug (fixed)

AHCI module failed to use Intel 82801FBM ICH6-M (8086 : 2653) controller.

Reported by: siarzhuk Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Boot problem is observed on laptop with following mass storage controller:

=== PCI bus, device #18: Mass Storage Controller (IDE) [1|1|80]

Current configuration: irqs [14][15]

io range: min 1f0 max 1f0 align 0 len 8 io range: min 3f4 max 3f4 align 0 len 4 io range: min 170 max 170 align 0 len 8 io range: min 374 max 374 align 0 len 4 io range: min 0 max 0 align 0 len 8 io range: min 0 max 0 align 0 len 4 io range: min 0 max 0 align 0 len 8 io range: min 0 max 0 align 0 len 4 io range: min 18a0 max 18a0 align 0 len 10

1 configurations

Possible configuration #0: irqs [14][15]

io range: min 1f0 max 1f0 align 0 len 8 io range: min 3f4 max 3f4 align 0 len 4 io range: min 170 max 170 align 0 len 8 io range: min 374 max 374 align 0 len 4 io range: min 0 max 0 align 0 len 8 io range: min 0 max 0 align 0 len 4 io range: min 0 max 0 align 0 len 8 io range: min 0 max 0 align 0 len 4 io range: min 18a0 max 18a0 align 0 len 10

Bus-dependent information: vendor id: 8086, device id: 2653

===

  • This laptop has SAMSUNG HM110JC ATA HDD attached to this controller.
  • No SATA/IDE switch options are found in BIOS Setup. Looks like it is either hard-coded to IDE mode or depends on type of attached HDD. Anyway I didn't know that my laptop has "SATA controller" until this problem arise. :-)
  • An attempt to load haiku on this hardware fails with "PANIC: get_boot_partition failed!" message.
  • In case I remove ahci bus module from Haiku partition - no boot problems observed and Haiku loads normally.

Unfortunately this laptop has no RS232 port to acquire debug log in compact text form. Attached screenshot contains one page of debug log during controller initialization phase. If you need complete log - I'll put other 20 pages onto Trac. :-)

Attachments (3)

IMG_3759-1.jpg (100.2 KB) - added by siarzhuk 12 years ago.
Screenshot with controller initialization log.
IMG_3759-1.2.jpg (100.2 KB) - added by siarzhuk 12 years ago.
Screenshot with controller initialization log.
syslog (91.3 KB) - added by siarzhuk 11 years ago.
System log of successful boot.

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by siarzhuk

Attachment: IMG_3759-1.jpg added

Screenshot with controller initialization log.

Changed 12 years ago by siarzhuk

Attachment: IMG_3759-1.2.jpg added

Screenshot with controller initialization log.

comment:1 Changed 12 years ago by siarzhuk

Sorry for duplicate attachment. Damned "Proxy Error". :-\

comment:2 Changed 12 years ago by marcusoverhagen

This appears to be a duplicate of bug #5.

comment:3 Changed 11 years ago by siarzhuk

hrev25746: I have performed default build and install onto partition. ahci module was build and linked to kernel/build. Following boot was successful and syslog contains lines like this:

2008-06-01 10:40:00 KERN: [35mahci:[0m ahci_supports_device 2008-06-01 10:40:00 KERN: PCI-IDE: Controller in legacy mode: cmd 0x1f0, ctrl 0x3f6, irq 14 2008-06-01 10:40:00 KERN: PCI-IDE: init channel... 2008-06-01 10:40:00 KERN: PCI-IDE: channel index 0 2008-06-01 10:40:00 KERN: PCI-IDE: bus master base 0x18a0 2008-06-01 10:40:00 KERN: PCI-IDE: init channel done 2008-06-01 10:40:00 KERN: IDE: scan_device_worker: bus 0x90bd3000, device-number 0 2008-06-01 10:40:00 KERN: IDE: create_device: bus 0x90bd3000, device-number 0 2008-06-01 10:40:00 KERN: IDE: setup_device_links: bus 0x90bd3000, device 0x90bca800 2008-06-01 10:40:00 KERN: IDE: scan_device_int: device 0x90bca800, atapi 0 2008-06-01 10:40:00 KERN: IDE: scan_device_int: waiting 100ms... 2008-06-01 10:40:00 KERN: IDE: scan_device_int: got a fast response 2008-06-01 10:40:00 KERN: IDE: scan_device_int: device found 2008-06-01 10:40:00 KERN: IDE: scan_device_worker: bus 0x90bd3000, device-number 1 2008-06-01 10:40:00 KERN: IDE: create_device: bus 0x90bd3000, device-number 1 2008-06-01 10:40:00 KERN: IDE: setup_device_links: bus 0x90bd3000, device 0x90bcac00 2008-06-01 10:40:00 KERN: IDE: scan_device_int: device 0x90bcac00, atapi 0 2008-06-01 10:40:00 KERN: IDE: scan_device_int: send_command failed 2008-06-01 10:40:00 KERN: IDE: scan_device_int: device 0x90bcac00, atapi 1 2008-06-01 10:40:00 KERN: IDE: scan_device_int: waiting 100ms... 2008-06-01 10:40:00 KERN: IDE: scan_device_int: no fast response to inquiry 2008-06-01 10:40:00 KERN: IDE: scan_device_int: status 0x00 2008-06-01 10:40:00 KERN: IDE: scan_device_int: busy bit not set after 100ms - probably noone there 2008-06-01 10:40:00 KERN: IDE: scan_device_int: aborting because busy bit not set 2008-06-01 10:40:00 KERN: IDE: destroy_device: device 0x90bcac00

Complete syslog is attached too.

Looks like this problem report can be closed. Thank you.

Changed 11 years ago by siarzhuk

Attachment: syslog added

System log of successful boot.

comment:4 Changed 11 years ago by siarzhuk

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.