Opened 11 years ago

Closed 11 years ago

#1784 closed bug (fixed)

Mail Inbox tracker window freezes

Reported by: cebif Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If I right click on the deskbar mail icon, then click on the inbox. When the window opens the messages at the top of the list are blanked out. The others are showing but they cannot be opened. The whole tracker window is frozen and cannot be closed from the tab exit button. The tracker has to be killed and the desktop restarted from Team Monitor. After that if I try to open a specific message from the Deskbar Mail daemon menu it will not open.

Change History (5)

comment:1 Changed 11 years ago by cebif

Assuming you have a Mail account setup. More specific steps to reproduce this bug are: 1) Right click on on the Deskbar Mail Daemon icon. 2) Click on settings. 3) Click apply button 4) Close the settings window. 5) Right click on Deskbar Mail Daemon and then go to folders and click on inbox subfolder. 6) Double click on a message. Result is message will not open and the Tracker window cannot be closed. It is then necessary to kill tracker and restart the Desktop. After that right clicking on the Deskbar Mail Daemon and going to the inbox messages menu then clicking on a message will not open it. It is necessary to kill Mail that is still showing on the Deskbar. After that messages can be opened by right clicking on the Deskbar then clicking on a message in the Inbox menu.

comment:2 Changed 11 years ago by cebif

Another way to cause this bug is: Skip 2 and 3 and after 6 the message will open then close it again. The Mail icon is then showing on the Deskbar. Try to open any more messages either by opening the inbox folder or right clicking on the Deskbar Mail Daemon then going to inbox folder messages menu, wont work. It is necessary to kill it and kill the tracker then restart the desktop

comment:3 Changed 11 years ago by jackburton

Can you retest with a more recent revision ? Thanks.

comment:4 Changed 11 years ago by cebif

I have retested with hrev24008. Bug is fixed. There is still some other bugs like daemon not starting when Haiku reboots and filters not working. I will search and see if they have already been reported.

comment:5 Changed 11 years ago by jackburton

Resolution: fixed
Status: newclosed

Since it was fixed recently, and judging by the bug symptoms, I think this had the same cause as #1645, and was therefore fixed in hrev23995.

Note: See TracTickets for help on using tickets.